[Solved] How to enlarge the letters in the applications ...?

Hi there,

I would like to know how to enlarge the letter in the applications itself in Arch, there are sometimes how to do it with the texts but I do not see any indication in Archlinux / fonts how to get a font size setting for the application larger than what it brings by default:

https://wiki.archlinux.org/index.php/Fonts

Another no less important problem is that when somehow it is possible to enlarge the letters then the frame in which the text content is, it leaves the screen off the sides, forcing you to have to move the content with the lower bar to be able to read it, the latter rather with browsers although it also happens with some applications when we can enlarge the font size, very cumbersome.

Is all this a problem itself of the particular application or of the system configuration in general?. If this has a solution. How can it be solved?.

And if this helps to explain myself something better: I remember that when I installed mxlinux the installer asked me to choose the font size, I think I put 1.5, I don’t remember very well … thank you very much.

The easiest way to adjust font scaling is probably via DE GUI tools. What Desktop Environment are you using?

Can you provide a screenshot?

Different DE’s do things different ways - but might you be looking for scaling of the entire screen? If you have a high DPI screen (say 3840x2160) you might well want 1.5 scaling just to read anything at all! In that case, rather than a font fix it might be a “display” fix.

Let us know what DE you are running as well, in case it has bearing on the fix. There usually IS a fix, but sometimes finding it takes a bit more…

Freebird54

Here in Endeavouros the main problem is rather with the second issue, for example, things like this:

But in Manjaro it is rather related to the first topic, the letters of some applications are too small.

Nothing of this is happening in mxlinux, the fonts are configurated at the begining, while instaling the system, but any way …

– can it be do it in Arch too?

[ i was writing while you posted]

My desktop Xfce4 …

[keos@keos-pc ~]$ cat /etc/*release
Arch Linux release
LSB_VERSION=1.4
DISTRIB_ID=EndeavourOS
DISTRIB_RELEASE=rolling
DISTRIB_DESCRIPTION="EndeavourOS Linux"
NAME="EndeavourOS"
PRETTY_NAME="EndeavourOS"
ID=endeavouros
ID_LIKE=arch
BUILD_ID=rolling
ANSI_COLOR="0;36"
HOME_URL="https://endeavouros.com/"
SUPPORT_URL="https://forum.endeavouros.com/"
BUG_REPORT_URL="https://github.com/endeavouros-team"
LOGO=endeavouros
[keos@keos-pc ~]$

 
If you need more information, please let' me know the commands since i m not an expert.

But as said before it only happen in Arch ...

Maybe this will be helpful to you?
https://wiki.archlinux.org/index.php/HiDPI#Xfce

Besides changing the DPI value (which for my big TV at a resolution of 1920x1080 is forced to 110) you can also adjust font sizes in systemsettings -> appearance -> fonts. Hope I translated the menue entries correctly.
In addition to that every browser I know offers an option to change the font sizes for web display. Or just use the offered zoom function in your browser. These settings will be stored and have to be set only once.

I’ll pop in what I use on XFCE as well. I have a couple of items that I paste into .bashrc in my home directory.

export GDK_SCALE=2
export GDK_DPI_SCALE=0.5

and I set the font DPI up to 120 here:


Which is the Appearance from Settings, in the fonts section. There are similar possibilities available in other Desktop Environments (DE’s), but I don’t yet know which you use.

Freebird54

@freebird54 (Xfce4) Yes, i already know this tool and it can fix many thing … but there are applications that can’t be fixed – that is why i want to know if the font of the whole system can be reconfigured.

For example, in Manjaro, now i elevated the DPI to 110 and is a ‘bit better’ for an application in question [focuswriter] but i can’t going up and up because for the rest … texts are now to big.

This is the bashrc:

#
# ~/.bashrc
#

[[ $- != *i* ]] && return

colors() {
	local fgc bgc vals seq0

	printf "Color escapes are %s\n" '\e[${value};...;${value}m'
	printf "Values 30..37 are \e[33mforeground colors\e[m\n"
	printf "Values 40..47 are \e[43mbackground colors\e[m\n"
	printf "Value  1 gives a  \e[1mbold-faced look\e[m\n\n"

	# foreground colors
	for fgc in {30..37}; do
		# background colors
		for bgc in {40..47}; do
			fgc=${fgc#37} # white
			bgc=${bgc#40} # black

			vals="${fgc:+$fgc;}${bgc}"
			vals=${vals%%;}

			seq0="${vals:+\e[${vals}m}"
			printf "  %-9s" "${seq0:-(default)}"
			printf " ${seq0}TEXT\e[m"
			printf " \e[${vals:+${vals+$vals;}}1mBOLD\e[m"
		done
		echo; echo
	done
}

[ -r /usr/share/bash-completion/bash_completion ] && . /usr/share/bash-completion/bash_completion

# Change the window title of X terminals
case ${TERM} in
	xterm*|rxvt*|Eterm*|aterm|kterm|gnome*|interix|konsole*)
		PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/\~}\007"'
		;;
	screen*)
		PROMPT_COMMAND='echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/\~}\033\\"'
		;;
esac

use_color=true

# Set colorful PS1 only on colorful terminals.
# dircolors --print-database uses its own built-in database
# instead of using /etc/DIR_COLORS.  Try to use the external file
# first to take advantage of user additions.  Use internal bash
# globbing instead of external grep binary.
safe_term=${TERM//[^[:alnum:]]/?}   # sanitize TERM
match_lhs=""
[[ -f ~/.dir_colors   ]] && match_lhs="${match_lhs}$(<~/.dir_colors)"
[[ -f /etc/DIR_COLORS ]] && match_lhs="${match_lhs}$(</etc/DIR_COLORS)"
[[ -z ${match_lhs}    ]] \
	&& type -P dircolors >/dev/null \
	&& match_lhs=$(dircolors --print-database)
[[ $'\n'${match_lhs} == *$'\n'"TERM "${safe_term}* ]] && use_color=true

if ${use_color} ; then
	# Enable colors for ls, etc.  Prefer ~/.dir_colors #64489
	if type -P dircolors >/dev/null ; then
		if [[ -f ~/.dir_colors ]] ; then
			eval $(dircolors -b ~/.dir_colors)
		elif [[ -f /etc/DIR_COLORS ]] ; then
			eval $(dircolors -b /etc/DIR_COLORS)
		fi
	fi

	if [[ ${EUID} == 0 ]] ; then
		PS1='\[\033[01;31m\][\h\[\033[01;36m\] \W\[\033[01;31m\]]\$\[\033[00m\] '
	else
		PS1='\[\033[01;32m\][\u@\h\[\033[01;37m\] \W\[\033[01;32m\]]\$\[\033[00m\] '
	fi

	alias ls='ls --color=auto'
	alias grep='grep --colour=auto'
	alias egrep='egrep --colour=auto'
	alias fgrep='fgrep --colour=auto'
else
	if [[ ${EUID} == 0 ]] ; then
		# show root@ when we don't have colors
		PS1='\u@\h \W \$ '
	else
		PS1='\u@\h \w \$ '
	fi
fi

unset use_color safe_term match_lhs sh

alias cp="cp -i"                          # confirm before overwriting something
alias df='df -h'                          # human-readable sizes
alias free='free -m'                      # show sizes in MB
alias np='nano -w PKGBUILD'
alias more=less

xhost +local:root > /dev/null 2>&1

complete -cf sudo

# Bash won't get SIGWINCH if another process is in the foreground.
# Enable checkwinsize so that bash will check the terminal size when
# it regains control.  #65623
# http://cnswww.cns.cwru.edu/~chet/bash/FAQ (E11)
shopt -s checkwinsize

shopt -s expand_aliases

# export QT_SELECT=4

# Enable history appending instead of overwriting.  #139609
shopt -s histappend

#
# # ex - archive extractor
# # usage: ex <file>
ex ()
{
  if [ -f $1 ] ; then
    case $1 in
      *.tar.bz2)   tar xjf $1   ;;
      *.tar.gz)    tar xzf $1   ;;
      *.bz2)       bunzip2 $1   ;;
      *.rar)       unrar x $1     ;;
      *.gz)        gunzip $1    ;;
      *.tar)       tar xf $1    ;;
      *.tbz2)      tar xjf $1   ;;
      *.tgz)       tar xzf $1   ;;
      *.zip)       unzip $1     ;;
      *.Z)         uncompress $1;;
      *.7z)        7z x $1      ;;
      *)           echo "'$1' cannot be extracted via ex()" ;;
    esac
  else
    echo "'$1' is not a valid file"
  fi
}

OK - I think I might have an idea of what’s wrong here - sorta. There are 2 different toolkits in wide use on Linux: GTK and QT5. They have separate settings. I just tried Focuswriter, and it does not allow for font changes that I can find - BUT there is something you can do. If you look for the QT5 Configuration tool (QT5 Settings in the menu), and select fonts, you can change the font and/or its size. This will have an effect in focuswriter, and the ‘working’ font can be bigger (I made a big change to 16, but your choices may differ).

The only problem is that it will also affect the menu fonts (they REALLY grow) but as the menus are rarely seen or used, perhaps you can live with that. It will also allow you to undo the changes you made elsewhere that were causing you problems :grin:

Hope this helps

Freebird54

PS - the HI DPI changes I suggested were for .bashrc-personal - and are not needed if your screen is NOT hi-resolution. I have a 4K screen, and senior citizen eyes, so I needed to do that as well as the DPI change in “appearance” for GTK use.
Fb

It works!!. :triumph:

I did’t know about this toll. I did the same you did 16 it is good for me, i’m a senior too, but don’t tell anybody …:no_entry_sign:

Thank you very much for your help!

I just want to add a bit of input - if in the end UI elements look too big, you can scale them down with xrandr. Run it first from command line without options and note the name of the connected display you’ll be using as the output.

xrandr

and look for the name of the display (‘connected primary’).

Then run:
xrandr --output display --scale 1.25x1.25
(where display is the name from the previous command)

You can experiment with the values - the bigger the value, the more zoomed-out it’s going to be. Once you’re content with how it looks, just write the line above into your ~/.profile and it will be loaded at every login. If it’s not the case for bash (I’m using zsh) you should probably put it into ~/.bash_profile or source ~/.profile from there.

1 Like

@Tasia91 thanks.

I will like to add too that here in Endeavouros, there is not problem with focuswriter … but any way, i’m not able to find this application at the menu, looking for QT5 i found nothing.

I order to scale QT apps can try to add these lines to your ~/.profile as well:

export QT_SCALE_FACTOR=2
export QT_FONT_DPI=96

And possibly:

export QT_AUTO_SCREEN_SET_FACTOR=0

and see if it works.

it is ok here, there is not problem with the size fonts in Endeavouros for focuswriter. The only problem is that it looks like the application is not installed and i can’t find it …

If you are meaning the QT5 Settings app - I wonder (meaning I can’t remember) if it came with XFCE, or with Kvantum in some way. If you don’t need it, though - just keep smiling!

Freebird54

No, no, no. :upside_down_face: It could be possible that maybe i will be tomorrow in the need of to get this Lents. :rage:

It is in xfce4 Manjaro. Do you know if it is it an AUR tool? because xfce4-goodies-meta is not installed here.

As a matter of fact what is the exact name for this application?

No problem, i already found it and installed, the name is:

qt5ct Configuration Utility

Thanks again to everybody!!