[SOLVED] High cpu usage kworker

I am a beginner to using Linux who just installed EndeavourOS yesterday on my Dell Latitude E7470, and I am experiencing some problems with it.
I have abnormally high cpu usage, with one core being always maxed at 80% or more. The offending process seems to be “kworker/3:2+pm”. I have tried to check the problematic “gpe” ( as per here : https://askubuntu.com/questions/176565/why-does-kworker-cpu-usage-get-so-high/233947#233947 ) but I do not find any value higher than 280 so I assume it is not the problem.

I also found this topic ( https://bbs.archlinux.org/viewtopic.php?id=235015 ) where plugging off the laptop apparently fixes the problem. The laptop’s battery I’m using is dead and I am always using it plugged, could that be related ? )

EDIT 1 : I have ran the diagnosis found here (https://askubuntu.com/a/421916 ) and I have a lot of calls related to the USB with no USB device plugged in :

[11674.871178] Call Trace:
[11674.871178] usb_hcd_submit_urb+0x828/0xbb0
[11674.871179] ? usb_start_wait_urb+0xc7/0x180
[11674.871179] ? kfree+0xc3/0x3d0
[11674.871179] ? check_preempt_wakeup+0x142/0x250
[11674.871180] usb_start_wait_urb+0x8a/0x180
[11674.871180] usb_control_msg+0xe9/0x150
[11674.871180] hub_ext_port_status+0x87/0x110
[11674.871181] hub_activate+0x155/0x820
[11674.871181] hub_resume+0x33/0x100
[11674.871182] usb_resume_interface.part.0.isra.0+0x73/0xb0
[11674.871182] usb_suspend_both+0xff/0x230
[11674.871182] usb_runtime_suspend+0x2b/0x70
[11674.871183] ? usb_autoresume_device+0x50/0x50
[11674.871183] __rpm_callback+0x44/0x110
[11674.871184] ? usb_autoresume_device+0x50/0x50
[11674.871184] rpm_callback+0x59/0x70
[11674.871184] ? usb_autoresume_device+0x50/0x50
[11674.871185] rpm_suspend+0x177/0x740
[11674.871185] ? hub_event+0x3f3/0x17f0
[11674.871185] ? usb_runtime_resume+0x20/0x20
[11674.871186] __pm_runtime_suspend+0x43/0x100
[11674.871186] usb_runtime_idle+0x2d/0x40

I do have a problem with the usb ports on this laptop. Should I deactivate them and how ?
EDIT : the problem was with autosuspend acting weird. used sudo pluma /etc/default/grub to find the GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=6166665e-0be1-4491-b2e1-7eb5422ff862 loglevel=3 nowatchdog" line and replaced it with GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=6166665e-0be1-4491-b2e1-7eb5422ff862 loglevel=3 nowatchdog usbcore.autosuspend=-1"
Thank your for the help

1 Like