[Solved]Gnome authentication dialog problem on Arch but not Endeavour

Hey all.
Bit of an odd one here and I’m not really sure if this is the right place to post it.

I recently installed Arch on one of my laptops with gnome and gdm and came across a problem with the authentication dialog.

When an application needs to request administrative privileges, usually, an authentication dialog should pop up prompting for authorization, however, this does not appear and whatever action the application was performing seems to go ahead without confirming authentication.

However, if I lock the gnome session with Super + L and then unlock it again, I can see the authentication prompt, but clicking either the authenticate or cancel buttons does nothing and the dialog remains open and stuck above all other content.

This seems to be an issue with any application that requires administrator authentication to perform an action. e.g. Changing the system keyboard layout in gnome settings or opening the pamac preferences window.

Today I’ve installed Endeavour OS on the same laptop and installed gnome and gdm and it does not have the same issue.

I’ve had a look at the /etc/sudoers file and the only difference is that the group with sudo enabled is wheel on Endeavour, but I set it up as sudo on the Arch install.

I’m guessing the Endeavour installer does something which I didn’t do when installing Arch manually, but I’m scratching my head as to what it could be and was wondering if this is a known problem which the Endeavour installer deals with?

I’ve also put a post up on the Arch forums (https://bbs.archlinux.org/viewtopic.php?id=248382) because at the end of the day, it’s a problem I have with Arch and not Endeavour, but I thought I’d post here to see if anyone had any ideas on why Endeavour does not present this problem.

Many thanks.

You have installed gnome-polkit and gnome-keyring packages?

Hi! you should set:

  • user to wheel group
  • add sudo rights to wheel group

Then add your user to sudoers, prefering add to an external file like /etc/sudoers.d/10-myuser

Better avoid adding your user to /etc/sudoers file directly, this is more prone to break.

If this is alright and still not working can be indeed what @Xterminator stated, though i belieave installing gnome at terminal should bring all this stuff already.

you can also check more info here https://wiki.archlinux.org/index.php/Sudo#View_current_settings


this could be it too.
password root

usermod -aG wheel myuser

1 Like

Bingo! That’s fixed it.

There is one thing I don’t understand though.

I did have %sudo ALL=(ALL) ALL in /etc/sudoers and was a member of the sudo group.
sudo worked in the terminal fine so the only issue was with the gnome authentication dialog,
but changing to %wheel ALL=(ALL) ALL and adding myself to wheel has fixed the issue.
Why does the group name matter in this case? Is the gnome authentication dialog ignoring the configuration in /etc/sudoers?


AFAIK wheel group is considered standard, not sure if there is any other reason than convention.


Read this


I understand the purpose of the wheel group, however, the default /etc/sudoers file contains

## Uncomment to allow members of group wheel to execute any command
# %wheel ALL=(ALL) ALL

## Same thing without a password

## Uncomment to allow members of group sudo to execute any command
# %sudo ALL=(ALL) ALL

so I assumed that the sudo group could be used as well.

Anyway thank you both very much for the help, much appreciated! :smile: