[SOLVED] Freezing in "System Settings"

My wife has an archaic Dell Inspiron 1720 which she rarely uses as it’s just way too slow on win10. In a last gasp attempt to resurrect it before it ends up being (cough) recycled I decided to give EnOS a try.

The online install went fine and I installed Plasma as the DE. Everything works fine (and is much more responsive than win10) until I try and access “System Settings” at which point the laptop will freeze. Occasionally I can get in to make changes but invariably if I try and make a change it will also result in a freeze and the only solution is to long press the power button.

I wonder if there may be a package I’m missing, but I have no idea what, or where to look to try and troubleshoot. Any help or advice is appreciated.

Is it possible from the Welcome screen to upload inxi -Fxxc0z and post the link.

1 Like

You should be able to access that here:-

Looks like you have LightDM installed? Did you install it and switch? Normally KDE is using SDDM? Or do you have multiple desktops installed?

First thing to check is also removing xf86-video-intel

I may have done, but it’s using sddm.

Interestingly I’ve installed xfce alongside and this DE has none of the problems Plasma is exhibiting. I may just opt to keep xfce and remove Plasma if I can’t get to the bottom of the problem.

I take it you installed Xfce after because you were having issues on KDE? Something must be messed up in KDE then.

Edit: I use KDE and don’t have any of that issue. My hardware though is much newer and more powerful also.

Correct. I’ll remove Plasma entirely then…

I thought Plasma would be a good fit as it seems, in it’s latest iteration at least, to be quite light on resources. The laptop is maybe just too old.

It’s hard to say. It may have just been a bad install for network reason? Or it just uses more resources than Xfce and it is only a dual core. :man_shrugging:

On one of my laptops System Settings would cause the system to freeze up on KDE Wayland but everything is fine with KDE on X11. Don’t know if that has anything to do with your situation; just something I’ve experienced.

My opinion regarding Plasma is that, though it’s more efficient than past releases, it’s still a full function desktop environment. With nothing except the desktop running it’s likely to consume 400-500 MB of RAM. IF you start a Web browser you will probably exceed 1 GB of RAM, if not more.

On a system over ten years old I recommend Xfce. If even that proves to be too much on resources use only a window manager such as IceWM, Openbox, etc.

I think if you have a powerful enough system i.e. processor, and current hardware specs then ram is not that significant a factor. I have 32 GB memory and my system rarely uses up to 1.5 GB under normal usage.

Well after several days investigating various DEs, NVIDIA issues etc. I believe the problem was more fundamental, in that the distros I was trying lacked proper support for the 32bit processor. I’ve opted for Debian i386 and all is functioning well. She hasn’t tried in yet but I think Debian/Plasma won’t be too big a stretch.
Kinda sad I couldn’t get an Arch based distro working but at least she’s now on GNU/Linux.

1 Like

" https://archlinux32.org/ "

Yeah found that only after Debian was installed. TBH I’ve spent far too long on this laptop, so Debian stays. :rofl:

It is a 64 bit processor? So I’m not sure why?

Not 100% sure how to interpret this. IIRC it came with a 32bit Windows Vista OS. When it was upgraded to win8.1 then win10 it remained 32bit. I’m beyond caring, she has a usable laptop now which was the objective. I have other projects to be getting on with.


Okay i see that but i looked at the specs for the processor.

Edit: But if it works good on 32 bit without freezing then no issue. MX linux also has 32 bit

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.