[SOLVED] Firefox freezes the system in Gnome 44

After the recent updates, using Firefox the system frequently freezes both when I type into a window or scroll through a window by the mouse. I need to use esc key to interrupt it.
Also, since Gnome automatically starts Firefox at the beginning of the session, now Firefox always starts in a black window that occupies the whole screen. So I have to manually close it and restart it. In this way it loses all the cards of the sites open in the previous session, despite the settings to maintain them.
It seems to me that version 44.1 introduces several bugs.
Does anyone else have noticed this behavior?

What do you mean? Gnome is not doing this out of the box. How did you tell gnome to start firefox?


1 Like

Probably hardly anyone else is starting FF on login with session-restore and umpty numbers of tabs to be restored?

What does this command show you after session-start, with FF still open (not closed)? - Start a terminal and run:
free -h
…and paste the output here, please. :wink:

1 Like

In Gnome Customization → Starting Application → Firefox

free -h
total used free shared buff/cache available
Mem: 7,6Gi 1,5Gi 4,9Gi 360Mi 1,2Gi 5,4Gi
Swap: 0B 0B 0B

The Firefox previous tab are 4 or 5. Before worked with many more.
Does not seem to lack available memory.

How many tabs (cards) are open in Firefox during this free -h result you posted? I guess only one?

There are 9

So you have enough free memory then for Firefox not to crash or freeze your system. It must be a different issue then.

I agree

Perhaps, someone else will come to chime in on this, as I don’t have a Gnome system currently, sorry.

You could post the output of inxi and post it here, according to the EnOS-Wiki.
Please see:

If you are using Wayland, can you check if the problem also happens when using X11?

1 Like


1 Like

The problem is precisely with Wayland… Whit X1 doesn’t happen.

1 Like

In Wayland, run Firefox through the terminal like this: MOZ_ENABLE_WAYLAND=1 /usr/lib/firefox/firefox %u
If no problems happens, we will edit firefox.desktop to run like that all the times.


Firefox starts but says “File not found” referred to %u… It tries to look for file:///home/ginsarch/%u (ginsarch is my user)
Without %u the command works correctly
And where do I find firefox.desktop to edit it ?

So you drop the %u from the command.

You could add a startup command like that one in gnome-settings for autostarting applications like that:
MOZ_ENABLE_WAYLAND=1 /usr/lib/firefox/firefox

In order to make firefox itself always open in session-restore mode:

Type in the address bar about:config (press Enter) (promise to be careful, if asked)
Type and look for the preference : browser.startup.page and set it’s value to 3

cp /usr/share/applications/firefox.desktop ~/.local/share/applications/firefox.desktop
nano ~/.local/share/applications/firefox.desktop

change Exec line from default to:

Exec=env MOZ_ENABLE_WAYLAND=1 /usr/lib/firefox/firefox %u

This will make Firefox runs natively in Wayland, not using Xwayland anymore.

You can read more about this env here: https://wiki.archlinux.org/title/firefox#Wayland

I believe that the bug you are facing is this one, really not sure:


Yes its happening with me as well but not on gnome, its on kde. Not only with firefox but also with any app that is not installed through pacman. like I installed visual-studio-code-bin from aur and neo4j-desktop.appimage from official website. the apps freeze and crashes after a while. I am unable to find any solution yet.

Your problem seems to be related to this:


The right file to modify is ~/.config/autostart/firefox.desktop.
The file ~/.local/share/applications/firefox.desktop didn’t work.
But now everything works again.
Thank you very much.