[SOLVED] Firefox changed my mouse cursor size?

Something weird going on here, when I use firefox it changes the size of my mouse cursor to maybe two sizes larger.

In firefox…

On my desktop wallpaper…

Any idea what is happening here? its totally triggering my OCD. :stuck_out_tongue_winking_eye:

Do you have a high dpi screen? Any chance you changed the resolution/scaling? Could be Qt vs GTK scaling issue.

Give some more info on you system (are you running kde, what graphics card etc), upper link of the forum webpage, help>forum log tool, providing information.

1 Like

EOS is on a vmware VM, and this is Xfce. Host is on windoze10, so its a VMware graphics. I find it strange that all the other apps are fine, its just when I have my cursor in firefox and it changes to a different size.

$ inxi -Fxxc0z --no-host
System: Kernel: 5.14.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 wm: xfwm
dm: LightDM Distro: EndeavourOS base: Arch Linux
Machine: Type: Vmware System: VMware product: VMware Virtual Platform v: N/A serial: Chassis: No Enclosure type: 1
Mobo: Intel model: 440BX Desktop Reference Platform serial: BIOS: Phoenix v: 6.00 date: 07/22/2020
CPU: Info: 2x 8-Core model: Intel Xeon E5-2698 v3 bits: 64 type: MCP SMP arch: Haswell rev: 2 cache: L2: 80 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 73557
Speed: 2299 MHz min/max: N/A Core speeds (MHz): 1: 2299 2: 2299 3: 2299 4: 2299 5: 2299 6: 2299 7: 2299 8: 2299
9: 2299 10: 2299 11: 2299 12: 2299 13: 2299 14: 2299 15: 2299 16: 2299
Graphics: Device-1: VMware SVGA II Adapter driver: vmwgfx v: bus-ID: 00:0f.0 chip-ID: 15ad:0405
Display: x11 server: X.org 1.20.13 compositor: xfwm4 driver: loaded: vmware unloaded: fbdev,modesetting,vesa
resolution: <missing: xdpyinfo>
OpenGL: renderer: SVGA3D; build: RELEASE; LLVM; v: 4.1 Mesa 21.2.2 direct render: Yes
Audio: Device-1: Ensoniq ES1371/ES1373 / Creative Labs CT2518 driver: snd_ens1371 v: kernel bus-ID: 02:02.0
chip-ID: 1274:1371
Sound Server-1: ALSA v: k5.14.7-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.37 running: no
Network: Device-1: Intel 82371AB/EB/MB PIIX4 ACPI vendor: VMware Virtual Machine type: network bridge driver: N/A port: 1060
bus-ID: 00:07.3 chip-ID: 8086:7113
Device-2: Intel 82545EM Gigabit Ethernet vendor: VMware PRO/1000 MT Single Port driver: e1000 v: kernel port: 2000
bus-ID: 02:01.0 chip-ID: 8086:100f
IF: ens33 state: up speed: 1000 Mbps duplex: full mac:
Bluetooth: Device-1: VMware Virtual Bluetooth Adapter type: USB driver: btusb v: 0.8 bus-ID: 2-2.1:4 chip-ID: 0e0f:0008
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: not found rfk-block: hardware: no software: no
address: see --recommends
Drives: Local Storage: total: 500 GiB used: 851.6 GiB (170.3%)
ID-1: /dev/sda vendor: VMware model: Virtual S size: 500 GiB serial: N/A
Partition: ID-1: / size: 491.07 GiB used: 25.35 GiB (5.2%) fs: ext4 dev: /dev/sda1
Swap: Alert: No swap data was found.
Sensors: Message: No sensor data found. Is lm-sensors configured?
Info: Processes: 321 Uptime: 1h 53m Memory: 15.6 GiB used: 1.86 GiB (12.0%) Init: systemd v: 249 Compilers: gcc: 11.1.0
Packages: pacman: 947 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.05

I’ve seen this with MATE, where the cursor size setting would change at some point (maybe when switching theme?), with different applications looking at different places the setting is stored. The usual fix for me was to reset the cursor size using dconf-editor,

No idea if this is the same for Xfce but it’s probably worth a look.

1 Like

Else have also a look here


Edit: sorry just realized this applies to kde…

Thanks for this, but this led me to the solution.

For future users using Xfce and having this issue, here is what you do to solve it. Open up the “Mouse and Touchpad” program in Xfce.


Set the Cursor size to some absurd number maybe 80 Size. Then set it back down to the lowest which should be a minimum of Size 16. This solved the issue for me, its like jumping life back into the cursor size setting.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.