[Solved] EOS on Hyper-V

Hi All,

Has anyone successfully installed new EOS release with GUI in Hyper-V (MS’s virtual machine platform) under Win10? After installation and reboot, the screen is black with only a small cursor on the screen indicating that X did not start (CLI is OK).

Per this post https://forum.endeavouros.com/t/running-endeavouros-in-hyper-v/590/4 RemoteFXVideo adapter is already added but the problem is still there.

From googling it appears that some boot parameters need to be added to grub entry (select ‘e’ before booting) go get X running but do not know which parameters and how to add them. Any pointer will be appreciated.

Thanks in advance.

Did you install xf86-video-fbdev

It is installed when I install EOS:
xf86-video-fbdev 0.5.0-1 (Installed)

Newt

From Xorg.0.log:`


@nhutnn
I am installing Xfce right now on Windows 10 HyperV. Not sure what your issue is?

@ricklinux
Are you able to see Xfce GUI?
When I installed Xfce (offline) X-server failed to start with the logs shown above. I can login to a shell but there is no X Windows GUI.

I added RemoteFX video hardware with the default settings before starting the VM.

Sorry, it took me a few minutes to get this loaded.

1 Like

What is your hardware as i don’t see that you need to add anything. I can go through the steps here.

Edit: I assume you have Windows 10 Pro?

@nhutnn
Start HyperV manager and click quick create.
Click on local installation source.
Uncheck this virtual machine will run Windows.
Click on change installation source.
Browse to the folder that has your Endeavour ISO (Downloads)
Click on the ISO and click open
Click create virtual machine.
It will create the virtual disc.
Then you have the options to change settings.
It shouldn’t be necessary.
Click connect.
Then you can start the virtual disc.
Once it is started and boots up you then install it to the virtual disc.

Not sure what your hardware is but let me know and try it this way.

Edit: I would just delete the current disc you made and start over.

1 Like

@nhutnn

So i asked if you have Windows 10 Pro? Also did you add the additional components on Windows 10 for Hypervisor from control panel/programs/programs and features/turn windows features on or off. Make sure all Hyper V components are installed and virtual machine platform i turned on. There is also subsystem for linux. You may not need them all but HyperV at minimum and i turned the others on too. If you don’t have Windows 10 Pro it won’t work because it’s missing some of the components. You also have to have virtual turned on in your Uefi or Bios.

@ricklinux
Yes, I have Windows Edu version which is same as Win Pro.
Per a post earlier I add that video hardware. I will try the start per your steps.
Thanks!

1 Like

What is your hardware? Video? Processor?

Edit: Is your computer Uefi or Bios?

@ricklinux
It is a Dell laptop with 16GB and an i7 processor so it would use Intel HD GPU.
I am creating a new VM using your procedure above, which is different from what I did (not the quick create way). This is a relatively new laptop so I think it is using UEFI, not legacy BIOS.

I’m using hyper v manager. Then I’m using the quick create feature. You can also use the other one which is Hyper V quick create. I don’t see any issue with the hardware as it is HD Intel 630 onboard graphics.

@ricklinux
Using your steps above (quick create) EOS starts fine on Hyper-V! I guess the difference was the way the VM was created. Creating a VM the old fashion way and then boot from ISO in virtual DVD did not work (X server fatal errors.)
Appreciate your help. Thanks!

May be your procedure above should be added to the wiki (installation on Hyper-V)?.

It could be i guess. I have quite a bit of experience using Vmware on Windows from years ago and i have used it on Linux also recently and i use Virtualbox and also Qemu/Virt manager. I like them all but my go to is Virtual Box on Linux.

Edit: Glad you got it working. Need any help we are here. I’ll do my best.

2 Likes