[Solved] Endevouros is unstable, after update

I don’t understand why you don’t have access to the forum? What do you mean.?

16 posts were merged into an existing topic: Nvidia-installer-dkms testing needed!

hello, you are in stable or testing

1 Like

@ricklinux, it is very rare but there are just a few of places that i’m not able to have access, (from endeavouros) the endeavouros forum, Manjaro forum, tutanota and amazon sometimes colapse …

I was able to install Midori and Dillo, it is the same with them, so the problem is not firefox.

@manuel i did a trick and i got this from the terminal in endeavouros:


> type or paste code here

1 Like

What desktop are you running currently?

type or paste code here

I’m not able to post now the result here, this is crazy …

type or paste code here

A post was merged into an existing topic: Nvidia-installer-dkms testing needed!

i dont want to be rude…

dont hiijack the treath !. :slight_smile:

even i dont know which hardware the op has.

1 Like

@keos what is your hardware ?

@ringo is right.
It is impossible to follow any thread discussion if all threads are in one thread.

Sorry folks I moved my hardware in the @pudge same problem, didn’t see was for @Keos

I reread all the Thread for better comprehension I will move all discussion between @ricklinux and me on the https://forum.endeavouros.com/t/nvidia-installer-dkms-testing-needed/3237

It looks like to many peoples posting at the same time and that’s why i was not able to paste …

Any way …

@manuel the others were commands too? i only got this results:

[keos@keos-pc ~]$ su
Contraseña: 
[root@keos-pc keos]# pacman -Qm
andscacs-engine 0.95-1
cliqz-bin 1.30.1-2
crafty 25.2-3
critter-engine 1.6a-3
ethereal-git 1180-1
firenzina-git 2.4.1.r40.17c9150-1
fruit 2.1-3
glxinfo 8.4.0-1
gull-git 3.0.4.r0.g8981253-1
komodo-10 10-1
pamac-aur-git 9.2.2.r18.gae50cf8-1
phalanx 23-3
pikaur-git 1.5.9.1.r0.g8419af2-1
protector-svn 1.9.0.r1134-1
senpai 1.0-1
stockfish 1:10-1
texel 1.06-1
trizen 1:1.62-1
xiphos-chess-git 113-1
zurichess 11-1
[root@keos-pc keos]# sudo pacman -Syyu
:: Sincronizando las bases de datos de los paquetes...
core                  135.1 KiB   877 KiB/s 00:00 [----------------------] 100%
extra                1643.8 KiB  2.13 MiB/s 00:01 [----------------------] 100%
community               4.8 MiB  2.05 MiB/s 00:02 [----------------------] 100%
multilib              161.9 KiB  1513 KiB/s 00:00 [----------------------] 100%
endeavouros            11.0 KiB  0.00   B/s 00:00 [----------------------] 100%
:: Iniciando actualización completa del sistema...
...el sistema ya está actualizado.
[root@keos-pc keos]# sudo pacman -S firefox
advertencia: firefox-72.0.1-1 está actualizado -- reinstalándolo
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquetes (1) firefox-72.0.1-1

Tamaño total de la instalación:  185.82 MiB
Tamaño neto tras actualizar:      0.00 MiB

:: ¿Continuar con la instalación? [S/n] s
(1/1) comprobando las claves del depósito          [----------------------] 100%
(1/1) verificando la integridad de los paquetes    [----------------------] 100%
(1/1) cargando los archivos de los paquetes        [----------------------] 100%
(1/1) comprobando conflictos entre archivos        [----------------------] 100%
:: Procesando los cambios de los paquetes...
(1/1) reinstalando firefox                         [----------------------] 100%
:: Ejecutando los «hooks» de posinstalación...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating icon theme caches...
(3/3) Updating the desktop file MIME type cache...
[root@keos-pc keos]#

@Keos

Did those commands help anything?

If not, I suggest you remove those AUR packages and then update with pacman again.

The reason is that AUR “packages” are not officially supported and can cause trouble.
If you make your system such that it has only official packages, then it is much more likely to work.
At least we can narrow down potential reasons for issues.

mayby is better to use pastebin.com and paste from /var/log/pacman.log , the newest lines of it.

but i also see you work in root interminal ? in root is sudo not needed …
and mayby some journalctl -x lines , not all , only recent.

personal those aur does not replace system packages, komodo , how high is that setup anti-virus ?

@ringo I just thought that it could be helpful maybe. Sorry for that. :frowning_face:

1 Like

It looks same as the problem I’ve had with NetworkManager which don’t allocate a DHCP ipv4 address.
Endeavour site cannot be reach without ipv4.

To see if you have an ipv4

$ ip a
Summary
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ff:ff:ff:ff:00:00 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.19/24 brd 192.168.0.255 scope global dynamic noprefixroute wlan0
       valid_lft 42750sec preferred_lft 42750sec
    inet6 9999:999:9999:aaa:bbbb:cccc:dddd:eeee/64 scope global dynamic noprefixroute 
       valid_lft 86357sec preferred_lft 86357sec
    inet6 ffff::999:9999:aaaa:bbbb/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

If you don’t have inet allocation like “inet 192.168.0.19/24”, that is the problem.

Just run in a terminal dhcpd, and then you’ve got an ipv4.

$ dhcpd

The workaround is here : [Workaround] How to fix connection bug within NetworkManager 1.22.2

1 Like

@ o’k i understand i wiil remove all this chess engines (que pena :rage:)
i will come back tomorrow, let’ see what happen :wink:. Thanks .

1 Like

There are also more official chess programs like gnome-chess with gnuchess. :slight_smile:

@manuel I decide to remove little by little the AUR packages and just to keep a few of them, most of the chess engines were left out then i cleaned all what was left behind, almost 3 GB of trash, many orphaned packages, configurations, etc, and it works!, the system is back again.
I will try to add just two o three more engines to see what happen, i know which ones are the more friendly…

Thank you very much.

*GNUchess is very weak it is at the computer chess rating list in the position # … (around the one hundred).

1 Like

For some reason I’ve never had a problem with updates. I always read about updates breaking distros but I’ve been distro hopping for 2 years and installing updates daily, and I never had a problem except for with a gentoo based distro