[SOLVED!] DWM desktop freezes when logged in when installed on kde plasma

am unable to run the dwm desktop on KDE plasma environment of endeavourOs (arch based linux distro) even after following all the procedures of downloading the packages and installing them {dwm, st, dmenu}

i also made the desktop entry in the path /usr/share/xsessions/dwm.desktop and added the script:
[Desktop Entry]
Encoding=UTF-8
Name=DWM
Comment=The Dynamic Window manager
Exec=/usr/local/bin/dwm
Type=XSession

Then i modified the .xinitrc file and added “exec dwm” to the file. Then i have also added the command “startx” at the end of .bash_profile

so now the desktop entry are shown during the login.
But when i try to choose the DWM option and try to login, the dmenu shows up but nothing else will work.

So can anyone please help me out with this problem.

Thank you in advance.

-Akanksh

welcome on the forum :enos:

On DWM it is mostly recommended to build it manually… also AUR provides PKGBUILD ready to use…
I do not see that you are running DWM together with plasma… like replacing WM on plasma with DWM? and you try to start DWM standalone while plasma is installed already?

If you use the AUR build it should give you a desktop entry already:

/usr/share/xsessions/dwm.desktop

What would give you an entry to start DWM with your DM (SDDM).

Freezing means in your case it really freezes or it is simply not configured? As per default, any WM is mostly an empty space without any configuration: https://dwm.suckless.org/tutorial/

1 Like

hello Joekamprad , Thanks for the help. Am i suppose to install the aur pkgbuild , on root level(“sudo makepkg -si”) or just the user level pkgbuild is ok ?(“makepkg -si”)

Thank you very much for the response

use yay:
yay -S packagename
If you want to use the AUR build
If not you should have a look at the archwiki:
https://wiki.archlinux.org/title/Dwm

and makepkg -si not at root if you want to use “pure” makepkg and not using an AUR helper

i have tried it as you said. but still its the same problem i am getting. i am attaching the how the dwm destop looks even after logging in.

Using sudo with makepkg is not allowed because of potential security problems.
The same applies to yay.

yes i have got that error. so i just did makepkg -si

I am still stuck over here itself, can anyone please help me out with this.

Thank you to everyone who has helped me till now. (@joekamprad @manuel)

But the problem still resides. So some more help is appreciated.

If you press Shift + Alt + Enter - Launch a terminal.

do you have a terminal filling the whole screen and you can type?

Edit: if yes, then you just need to install a wallpaper to get rid of the login background…

1. Install feh
$ sudo pacman -S feh
2. Set wallpaper
$ feh --bg-scale foobar.jpg

1 Like

Welcome to :enos: forums.

The issue with helping you is the problem is not clear to the community.

Are you trying to run dwm inside KDE? or are you trying to run dwm as a separate desktop environment?

We know, you’re here :smiley:.

From where did you followed the steps? it would be better if you link or show those to the community.

If you are able to log in after choosing dwm from the SDDM log-in screen that means you can use dwm. And you know dwm is a windows manager not a desktop environment like KDE, GNOME, or XFCE.

As @Zircon34 said if you see a full-screen terminal after pressing the key combo that means your dwm is working.

1 Like

Thanks for the help @Zircon34 made it clear. and dwm is now working it was my mistake. i thought my dwm was frozen but in actual it was not. when i followed @Zircon34 instruction it was clear.

Thank you once again.

The community is very very very helpful :slightly_smiling_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.