[SOLVED] Dropbox Will Not Install on One of My Computers

Here is my problem:

[verix-custom@verix-custom ~]$ yay -S dropbox
:: There are 4 providers available for dropbox:
:: Repository AUR

    1. dropbox 2) dropbox-gtk2 3) kfilebox 4) kfilebox-qt5-git *

*Enter a number (default=1): *
:: Checking for conflicts…
:: Checking for inner conflicts…
[Aur:1] dropbox-129.4.3571-1

  • 1 dropbox (Build Files Exist)*
    ==> Packages to cleanBuild?
    ==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
    *==> *
    :: PKGBUILD up to date, Skipping (1/1): dropbox
  • 1 dropbox (Build Files Exist)*
    ==> Diffs to show?
    ==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
    *==> *
    :: (1/1) Parsing SRCINFO: dropbox

:: PGP keys need importing:

  • → 1C61A2656FB57B7E4DE0F4C1FC918B335044912E, required by: dropbox*
    *==> Import? [Y/n] *
    :: Importing keys with gpg…
    gpg: WARNING: unsafe permissions on homedir ‘/home/verix-custom/.gnupg’
    gpg: key FC918B335044912E: no user ID
    gpg: Total number processed: 1
    problem importing keys
    [verix-custom@verix-custom ~]$

I have tried installing Dropbox via yay, via pamac-aur-git, and bauh. I have also tried installing dropbox-gtk2. Nothing works.

I do have Dropbox installed on my other computers, all running EndeavourOS. Dropbox installed easily and perfectly on those other ones.

Here is information about this particular computer:

[verix-custom@verix-custom ~]$ inxi -Fx
System:    Host: verix-custom Kernel: 5.13.13-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Xfce 4.16.0 
           Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Laptop System: Notebook product: P9XXEN_EF_ED v: N/A serial: <superuser required> 
           Mobo: Notebook model: P9XXEN_EF_ED serial: <superuser required> UEFI: INSYDE v: 1.07.03 date: 01/15/2019 
Battery:   ID-1: BAT0 charge: 56.9 Wh (100.0%) condition: 56.9/56.2 Wh (101.2%) volts: 17.0 min: 15.2 model: Notebook BAT 
           status: Full 
CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake note: check rev: A cache: L2: 9 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 1340 3: 3044 4: 1503 5: 838 6: 878 7: 877 8: 900 
           9: 900 10: 1004 11: 900 12: 900 
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: CLEVO/KAPOK driver: i915 v: kernel bus-ID: 00:02.0 
           Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: CLEVO/KAPOK driver: nvidia v: 470.63.01 bus-ID: 01:00.0 
           Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 1-8:2 
           Display: x11 server: X.Org 1.20.13 driver: loaded: intel,nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 1920x1080~144Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           Device-2: NVIDIA TU106 High Definition Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           Sound Server-1: ALSA v: k5.13.13-arch1-1 running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.34 running: no 
Network:   Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel port: 5000 bus-ID: 00:14.3 
           IF: wlan0 state: up mac: d0:c6:37:d9:5b:e3 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK driver: r8168 v: 8.049.02-NAPI 
           port: 3000 bus-ID: 08:00.0 
           IF: enp8s0 state: down mac: 80:fa:5b:67:8b:27 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus-ID: 1-14:4 
           Report: bt-adapter note: tool can't run ID: hci0 rfk-id: 1 state: down bt-service: disabled rfk-block: hardware: no 
           software: no address: N/A 
Drives:    Local Storage: total: 931.51 GiB used: 14.72 GiB (1.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB 
Partition: ID-1: / size: 915.32 GiB used: 14.72 GiB (1.6%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 511 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 270 Uptime: 46m Memory: 31.07 GiB used: 2.05 GiB (6.6%) Init: systemd Compilers: gcc: 11.1.0 
           Packages: 1417 Shell: Bash v: 5.1.8 inxi: 3.3.05 
[verix-custom@verix-custom ~]$

Can anyone point the right direction to me to install Dropbox on this computer?



It looks like it is failing to import the key.

You could try manually importing the key FC918B335044912E

You should probably also fix the permissions on ~/.gnupg

1 Like

Dear dalto,

How do I do each one of your suggestions? In other words, (1) how do I manually import a key and (2) how do I access and then fix the permissions on ~/.gnupg (and what would I set those permissions to)?

I’m sorry but I need explicit instructions.


I found some instructions to manually import keys on Arch Linux’s site and I tried using the instruction sudo pacman-key --recv-keys FC918B335044912E and, when that didn’t work and I saw a PGP key that had to be imported (1C61A2656FB57B7E4DE0F4C1FC918B335044912E) I tried installing that key using the same command.

But nothing worked.

Any thoughts?


As I’m writing this (on my affected computer), I am running the command sudo pacman-key --refresh-keys and it’s running and showing many, many errors, far too many to show here.

Here’s just one (picked at random):

gpg: error retrieving 'daniel.wallace@plangrid.com' via WKD: No data
gpg: error reading key: No data
gpg: error retrieving 'daniel.wallace12@gmail.com' via WKD: No data
gpg: error reading key: No data
gpg: error retrieving 'danielwallace@gtmanfred.com' via WKD: No name
gpg: error reading key: No name

Some of the other errors show the key(s) which cannot be downloaded.

Can anyone help me?


pacman-key --refresh keys will take a while to complete, and yes you will see a lot of messages like that.

Are you trying to import a key from the sks-keyservers? Because that service is not working any more.

Check the AUR page for the package and read the latest comments; you might want to try gpg --keyserver hkp://pgp.mit.edu --recv-keys FC918B335044912E

This uses the mit.edu keysserver, not the sks-keyserver.

1 Like

I tried your command but it didn’t work. I tried reading what was in the AUR page but the information there is quite confusing to me.

When I try to install Dropbox I keep getting gpg: WARNING: unsafe permissions on homedir ‘/home/verix-custom/.gnupg’ when I try getting the key.

Here is the output of /home/verix-custom/.gnupg/gpg.conf:

keyserver-options timeout=10
keyserver-options import-clean
keyserver-options no-self-sigs-only
keyserver hkp://keys.openpgp.org

Should anything in that be changed? If not, what should be changed?

I have not had any trouble installing Dropbox on any of my other computers running EnOS. This is confusing and frustrating to me.

I hope that someone can tell me the solution.



chmod og-wrx ~/.gnupg

Dear dalto,

I ran your command chmod og-wrx -/~gnupg (two times: once “regular” and the second time as “root”).

Then I tried installing Dropbox and I got the same errors as before.

So I rebooted the computer and ran:

(which was another key which said it was required by Dropbox) and then I rebooted again.

Then I tried installing Dropbox - and THIS TIME it WORKED!!! Obviously, both commands were necessary.

My wife says that I’m “anal” - after all, I have Dropbox on all of my other computers so why do I need it on this one?

Well, she’s probably right - I probably am “anal” - but I want all of my computers to look alike and work alike.

Anyway, I can’t thank you dalto and you Stagger_Lee for your help and for your patience with me.

You guys (and everyone else on this forum) are positively the GREATEST!!!

Thank you again very much.



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.