[Solved] Changes to screen config don't persist after reboot

Hi guys, new user here. I’m really impressed with Endeavour so far. Almost everything worked right out of the box.

There’s just one thing I can’t figure out. I use i3 on a dual monitor system (laptop plus external screen). I have configured the screens with arandr, put the file in .config/i3/scripts, made it executable, and use “exec --no-startup-id /.config/i3/scripts/i3_asus.sh” in my i3 config file. I have also tried setting the screens directly with xrandr. i3 just ignores it on startup and falls back to its original setup which mirrors the displays. This is obviously not ideal.

Am I using the wrong syntax? Or the wrong file? What does the endeavourosdefault config file do? I have so many questions. :slightly_smiling_face:

Thanks for listening. Hope someone can help.

Typo? Have you missed the “~” off?

exec --no-startup-id ~/.config/i3/scripts/i3_asus.sh”
1 Like

Good catch, thanks! I’ve fixed the typo, but unfortunately that hasn’t solved the problem.

Does the script work if run from the command line?

Yes, no issues there.

As a workaround, I now configure the screens with xrandr in the config file:

exec xrandr --output eDP-1-1 --mode 1920x1080 --pos 0x0 --rotate normal --output DP-1-1 --off --output HDMI-1-1 --off --output HDMI-1-2 --primary --mode 1920x1080 --pos 1920x0 --rotate normal

This works as intended.

Edit: I’ll mark the question as solved though I’m still not quite sure what’s going on. Thank you for your help!


if you link to a scriptfile (sh e.t.c.) you need to make this scriptfiles executable, or they can not be executed :wink:

He did.

i do test this here on several installs and it does work, trhe only issue i got is inside vms where i need to run xrandr script for lightdm too as it will screw the screen after logging in to i3

That’s interesting, thanks for giving it a try. I’m not on a vm, but I do use Lightdm. I’ll look into it some more.