[SOLVED]Can't set new keyboard shortcuts in KDE

When I try to set keyboard shortcut for Audacious it has no effect. Same thing with Kate. I have never experienced such behaviour with any other KDE distros. What could be the problem?

Is khotkeys installed? There was a problem a few weeks back, when it was accidentally orphaned.

1 Like

It was installed. I uninstalled it and then installed again. No effect. When I look into .config/kglobalshortcutsrc I can see the shortcut for Audacious is there.

What are the shortcuts for kate? I will try and replicate.

For Kate I set shortcut Ctrl+K

Did you check to see that key combination was not already assigned?

Actually, I’m not sure about that. But I tried some other key combinations which certainly were’nt assigned and they didn’t work either.

Did you check if their was a default keybind for Kate?

Well, I’m not sure about Kate, but Ctrl+M key combination I tried for Audacious was already reserved for something else. I have always managed to use it anyway with other distros.

Can we see what the setting you set looks like?

Is it necessary to install something like this in Xfce? No shortcut with Audacious (volume control) works for me either.

Here it is.

Works here, did you set in custom shortcuts?

Ctrl+m is used by a lot of applications to show and hide the menu, so may get overridden.

1 Like

Oh, I have always used global shortcuts and they have worked just fine. Custom shortcuts are of course a proper way to do it. I’m so dumb… :confounded:
Thanks for your help. Problem solved… :blush:

1 Like