[SOLVED]Can't read/write without sudo

Hello everyone:)

I mounted an ssd(ext4) today but Ican’t read/write folders without using sudo in the console. How can access the ssd without having to use sudo because I’d like to use it as a drive for games

I already tried sudo usermod -a -G root $USER. That didn’t work.

Unfortunately not a good idea, better to remove it. See man usermod for more info.

How did you mount it? What’s the filesystem?

There are lots of mount options available. See

man mount
man fstab

for more info. In fstab you probably want to use options uid and gid.

1 Like

Hello @manuel :grin:

Thank you for your response :blush:

  1. uid and gid aren’t valid options for ext4.

  2. I tried both mount and fstab or rather a combination of them.

But I found the solution. I just had to use mount and then:
chown -R <user id>:<group id> <mount directory>

That was the kind of command I initially searched for but couldn’t find.

I found the solution here: https://unix.stackexchange.com/questions/298141/unrecognized-mount-option-uid-33-or-missing-value/298168#298168

1 Like

Great that you got it solved despite some misleading help! :wink:

Yeah, you’re right, sorry about that. Some other filesystems support them.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.