(SOLVED) Brother printer HL-1110

Hello i have got a Brother HL-1110 laser printer and i have tried printing but all i get is blank pages?
any help please?
thank you.

Did you install the correct drivers for this printer?

This one is it: https://aur.archlinux.org/packages/brlaser-git according to (https://wiki.archlinux.org/title/CUPS/Printer-specific_problems#Brother)

yay -S brlaser-git should install it.

On top of this you will need to install additional packages like cups and ghostscript.
Check this page for more info: https://discovery.endeavouros.com/printers/printers/2021/03/#network-printer

These two lines in particular are of interest from the link above:

sudo pacman -Syu cups cups-browsed cups-filters cups-pdf system-config-printer --needed
sudo pacman -Syu ghostscript gsfonts foomatic-db-engine foomatic-db foomatic-db-ppds foomatic-db-nonfree foomatic-db-nonfree-ppds gutenprint foomatic-db-gutenprint-ppds --needed

Welcome on the purple side :enos:
brlazer lists the pronter:

Also there is a chance that it also supports driverless printing.
Most modern Brother printer does.

Some info is missing to see if issue is the driver or may setup is incomplete.

  • Is cups installed and enabled?
  • is the printer connected over Network or usb?
  • are any extra driver packages installed to get it controlled?

I do use a brother laser printer here over network without any need to install or setup the specific printer, only enable cups-browsed service and open the firewall for mdns.
As i suggest on the wiki article too.

Thank you i will try later and let you know.

thank you all working.

2 cents as a Brother HL2315 owner… you didn’t ask for it but when it comes to printers I avoid Cups, their website. their help. Don’t ever want 3rd party help w/ the printer.
I will successfully get printer drivers this way:

  1. manufacturer targz. if they only have rpm or deb then
  2. search AUR, somebody had my model there.
  3. if Endeavour print settings does NOT have your model then I sometimes do The Big Fakeout where I select drivers from a model a number above or a number below my own. 75% success rate here.

I’m excited about a future world with driverless printing. have no idea how it works but I know it’s getting popular.

i use it every day :wink:
enabled cups-browsed avahi-daemon is running and printer is simple there ready to print no setup for the printer nothing it simply shows up.
Firewall needs to be set to home-zone as this will open mdns multicast what is needed for adding printer

yea pretty bloated piece of … still waiting for the fork from one of the original devs to rise up…

is that what avahi is for? all these years I had no idea :slight_smile: . seriously.

yet another thing I will forget :wink:

i got you all very annoying to do… but we have 2024… security is at risk… go buy a smart light bulb – connect it to your local network and wonder why it causes that much traffic pinging other computers all the time? And… it stops somehow to work properly when you stop its permission to reach the internet?

And i see also the issue with printing on Linux… not to say it’s almost the same way annoying on Windows and and worse on mac.

But we got it that far that you only need 2 commands to run if your printer supports driverless printing.

1 Like

the IOT is a world I don’t need to live in. that’s got to be the chattiest, most intrusive, vulnerable attack vector in all of computing but no real payoff for the jokers: I guess you could set someone’s fridge to 99 degrees as a prank…

But I would like to make avahi work for me, though. you did plant a seed. what I love about Linux is I never run out of functional things to try

1 Like

sudo firewall-cmd --set-default-zone home
sudo systemctl enable cups-browsed

and reboot

systemctl status avahi-daemon

In case you have selected printer support on initial install it will run… same for cups…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.