[Solved] Brother Printer "Filter failed" Error

I have a Brother MFC-8810DW printer connected via USB to my newly installed EnOS system (KDE Plasma). I have installed the printer and scanner drivers from AUR. (Scanning works fine, btw.)

I have tried to install the printer from the KDE System Settings control panel, as well as via the cups http://localhost:631 on my firefox browser. In both scenarios, it appears that the printer is installed correctly. I can print a Self Test Page from the maintenance options. I can poll the printer for its default options. But, I cannot print a Test Page or a document. It gets stuck in the print queue with the message “Filter failed.”

I have polled via lsusb and it finds the printer:

Bus 002 Device 005: ID 04f9:02d4 Brother Industries, Ltd MFC-8810DW

I have followed the EnOS wiki on the printer topic, without finding anything wrong so far. The output of the avahi-daemon is:

systemctl status avahi-daemon
● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
     Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2020-08-11 13:26:11 EDT; 40min ago
TriggeredBy: ● avahi-daemon.socket
   Main PID: 701 (avahi-daemon)
     Status: "avahi-daemon 0.8 starting up."
      Tasks: 2 (limit: 18818)
     Memory: 3.0M
     CGroup: /system.slice/avahi-daemon.service
             ├─701 avahi-daemon: running [hpz230office.local]
             └─709 avahi-daemon: chroot helper

I have hit the wall with my diagnostic skills and would appreciate some assistance as to what more I should try. I am fairly sure that it is something simple, but I’m at a loss.

TIA for any assistance!

Barry

Looks like a communication issue.
There are multiple ways to connect your printer. From my experience with wireless Brother printers the AppSocket/JetDirect approach works best.

1 Like

Thanks, but that also failed with the same “Filter failed” error, as did using ipp and http. Could this be an issue with a misconfigured lpdwrapper?

Hmm not sure, but here is something more that you could try that is unintuitive:
cups-pdf is apparently also a needed package for the [wireless Brother] printer to work.

If this printer is connected to the computer via USB, why are you looking at ipp and http? These are networking protocols.

Let me do some research as it has been a LONG time since I hooked up a local printer on USB.

Pudge

@nate cups-pdf is installed

@Pudge Yes, this is connected via USB and I was not thinking clearly. I couldn’t get it working via usb connection, so I tried other options. Mea culpa.

I have looked at the arch wiki re: filter failed error, but don’t see (read: I’m not able to understand) anything that may be helpful, here:
https://wiki.archlinux.org/index.php/CUPS/Troubleshooting#CUPS:_“Filter_failed”

In a terminal window
$cat /var/log/cups/error_log should reveal which filter is causing your grief.

Then we can go from there.
What are we working on now? USB, wireless, or networked?
Pudge

for case USB , cupds needs ipp-usb added

No particular expertise here, but I do have a Brother hooked up with USB. I found that after using the scanner, I had to change ownership of the device back to the printing from the scanning - if you see what I mean. Not on the relevant machine at the moment - but will try to figure out the details if you need them. I was surprised that permissions entered the equation at all - but it ‘fixed’ the problem…

Here is the link to my command, ‘cat /var/log/cups/error_log’

http://ix.io/2tV8

Could this line be telling?

D [11/Aug/2020:15:27:37 -0400] [Job 46] PID 24134 (/usr/lib/cups/filter/brother_lpdwrapper_MFC8810DW) stopped with status 113 (Permission denied)

Thanks so much for your help!

@Stephane Thanks. I’m going to try direct usb connection for now, not using ipp, but noted this information.

@freebird54 I would appreciate more information on this, as I don’t understand what changes the permission back and forth.

@bkaplan

https://endeavouros.com/docs/hardware-and-network/printers/

Edit: I also have a Brother laser printer hooked up via usb with cups. I installed the printer from the AUR for mine.

I tried to follow that wiki post faithfully before posting here, but couldn’t progress past this filter -related error. I’m trying to figure out what I may have missed. Thanks for any ideas.

Edit: and I am using the aur drivers specific to my printer

That line is very telling. Here is what I have with my Brother DCP-l2550DW
Terminal window: $ ls -al /usr/lib/cups/filter

lrwxrwxrwx 1 root root     61 Jun 14  2018 brother_lpdwrapper_DCPL2550DW -> /usr/share/brother/Printers/DCPL2550DW/cupswrapper/lpdwrapper

This is a symlink to the proper lpdwrapper. Permissions should be lrwxrwxrwx root root

$ ls -al /usr/share/brother/Printers/DCPL2550DW/cupswrapper
-rwxr-xr-x 1 root root 26369 Jun 14 2018 lpdwrapper

Check the permissions and owners of these two files.
I have installed quite a few Brother printer/scanners and never had permission problems before.

Here is what is installed on my setup
$ pacman -Q | grep cups
cups 2.3.3-2
cups-filters 1.27.5-1
cups-pdf 3.0.1-5
cups-pk-helper 0.2.6-4
libcups 2.3.3-2

In particular cups-filters 1.27.5-1

My command yields:

$ pacman -Q | grep cups
brother-mfc8810dw-cups-bin 3.0.2-1
cups 2.3.3-2
cups-filters 1.27.5-1
cups-pdf 3.0.1-5
libcups 2.3.3-2
python-pycups 2.0.1-1

I do not have a /usr/shar/brother/ folder whatsoever, nor a symlink to the lpdwrapper in /usr/lib/cups/filter.

Perhaps I should try reinstalling the aur package? Or should I manually recreate your above structure using the packages (seemingly correct) at /opt/brother/Printers/MFC8810DW/cupswrapper/ ?

https://aur.archlinux.org/packages/brother-mfc8810dw-cups-bin/
Look at this web page from the AUR
There are a few things that bother me
first, it is a bin file

It lists the source as a .deb package, which I guess works but is not normal in a PKGBUILD

|First Submitted: |2019-11-19 19:15|
|Last Updated: |2019-11-19 19:15|

This page has the Maintainer listed as “orphan”
This IS the AUR. So who knows if it ever worked in the first place.

Let me download the drivers in rpm format and see if I can retrieve the PPD file. Then in localhost:631 in the driver selection page you can enter the PPD and try that.

Pudge

Okay, I extracted the PPD file from the RPM package and put it on my website. Download file
From my web site.
I would suggest using pacman to remove the brother-mfc8810dw-cups-bin 3.0.2-1 package. If you end up needing it, yay is just a step away.
In localhost:631
If you are still trying to connect through USB, on the first page where it lists detected printers, I believe you need to check one of the choices under “Local”
Then on the page where it says to enter the preferred driver OR enter a PPD, browse to the PPD file you downloaded then select that.

I don’t know if this will work, but it is worth a try.

Pudge

1 Like

Thank you, trying now. Remind me, is it best practice to use my local user or the root account in the localhost:631 setup?

When you click on add printer, it asks for a password.
I always enter “root” then root’s password.

Pudge

1 Like

Thank you for that. So now, it acts as though it is printing from the software side; however, the data light on the printer does not start flashing, and no output actually occurs.

So that I have a clean error_log file for the current configuration, I deleted the old one, rebooted, and tried printing again. There is no error reported in the printer queue. Here’s the current output from ‘cat /var/log/cups/error_log’:

http://ix.io/2tVO

I don’t see anything other than perhaps a misconfiguration in the /etc/cups/cupsd.conf file. Does that need to be somehow regenerated? I’m at a loss.