[SOLVED] Battery not charging anymore after threshold set

Hi :slight_smile:
I have a problem I can’t really get my head around, so I hope that I’m going to find some help here. I’m not completely new to linuxin general, but faily new to arch based systems and certainly would not call myself a proficient user when dealing with os related problems.

I have a Asus Vivobook Flip 14 (hardware log: https://clbin.com/mgZhg , boot log: https://clbin.com/P6NM6 ) with eos and plasma as de installed.
I wanted to set a threshold for battery-charging to 80 to increase its lifespan and followed this article https://wiki.archlinux.org/title/Laptop/ASUS#systemd_service to create a systemd-service that sets the content of /sys/class/power_supply/BATT/charge_control_end_threshold to 80. I took this route because when I set the value with the kde plasma energy gui it just kept resetting itself back to 100 after closing the window.

At first I thought that it worked, because my laptop was charged to 85% and it did not the panel-widget said, that the system is currently not charging.

A few days later I realized my laptop device sits at 47% and I realized, that it still won’t charge, so I changed the threshold value back to 100 but nothing changed. After a little bit of playing around I realized, that even when linux is not booted it refuses to charge the battery, e.g. when turned off or when I’m inside the bios.
Bios itself has no such option that allows me to limit the treshold.

So, yeah, my current situation is as following:
connected to AC: battery sits at a constant level, not gaining and not losing any charge, wether the device is turned off or not
disconnected from AC: battery loses charge as expected.

For now I would be really happy, if charging would work again.

1 Like

Hey, welcome to the eos forum.
Could you provide the link to the pastebin created by the following command. This will print out the files two directories deep for /sys/class/power_supply and create a pastebin.

find -L /sys/class/power_supply/ -maxdepth 2 -type f -exec head -1000 -v {} \; | curl -F 'clbin=<-' https://clbin.com

Maybe load setup defaults in the bios and boot to a EOS live iso to eliminate as many variables as possible.

I have a similar/same problem. My new laptop battery used to charge at 94%. But once charged unplugged and drained battery, it recharged later only to 79% and it also says not charging and stays there and it wont charge past 79%, even after I set threshold stop at 85%. I even used tlp and tlpui to set to 85% and it does go to 85% but then overnight it just reverts back to 79% and says ‘not charging’ even if plugged into charger? So I can’t increase charging threshold either.

(MSI Modern 14 laptop, Ryzen 7 5700U).

What’s the minimum set to? If your within parameters, it won’t charge.

Well…the problem seemed to have eliminated itself. Last Night when the device was plugged into the ac the battery light was blinking orange, which indicates that the battery is under 10% charge (which was not the case) or that there is some kind of syncing problem. I decided to take a break and went to sleep, turned the device off and unplugged it form ac.
Now several hours later when I woke up I plugged it back in and started into the bios the reset the defaults like @daniel adviced me to do and realized, that the charging jumped from 36% to 37%. Regardles of that I still resetted my settings and only deactivated secureboot again for eos to be bootable.

Now my system has started and my battery is charging again, I can’t exactly tell if it was a desyncing error and if the time the laptop sat unplugged somehow made it sync the battery again, but it certainly looks like that for my newbie-eyes :smiley:

What’s the minimum set to? If your within parameters, it won’t charge.

As far as I can tell there is/was no minimum set.

Thank you very much for your assistance and wish you all a very nice day.