[Solved] Bad ping in wifi connection

Ok, at start here is some info of my network:

[mardi@mardi-82l7 ~]$ inxi -Na
Network:
  Device-1: Realtek vendor: Lenovo driver: rtw89_pci v: N/A modules: rtw89pci
    port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:8852 class-ID: 0280

Because my laptop needs a wifi driver for Realtek RTL8852AE I have installed rtw89-dkms-git from AUR. So far it has worked without problems. But few days ago I noticed weird behaviour of my wifi speed. The speed is ok, but ping suddenly went higher than before. It’s usually around 30 ms, but now near 100 ms. I think it has something to do with that wifi driver. I remember seeing some updates for it some time ago.
I have a RT5370 Wireless Adapter for those cases when I have had problems with wifi and everything seems to work just fine with it. But I would like to get my wifi work normally without it, because my laptop has only 2 usb ports and that wireless adapter takes now one of them. Any solutions? Is downgrading wifi driver possible?

It is my understanding that the 5.16 kernel will support the RTL8852AE.
The only information i see looking quickly is the following.

So I wait until the 5.16 kernel is available in repos?

I don’t see any other info currently. This is the latest Realtek WiFi 6 AX chip. If it gets support in the 5.16 kernel then you won’t need the AUR package. I guess it’s a wait and see what happens between now and then.

Edit: This is just what i gather from reading the little info i can find.

Ok. That bad ping troubles me only when I play Supertuxkart online. Until it gets fixed I’ll manage with that wireless adapter… :wink:

Are you sure it’s not something to do with the site?

No, it’s not the site. Speedtest.net shows this:

1 Like

Well it’s obvious you have enough bandwidth. Have you tried resetting your router? Maybe speak with your service provider and have them check your lines and equipment. It could be a routing issue somewhere along the route causing it with lost packets. :man_shrugging: The new WiFi is AX standard and will connect with whatever standard your router is. It could be the a driver issue with this new hardware. But if it’s only this site then has to be another issue.

Yes, resetting my router is the first thing I do when I have problems with wifi. But it wasn’t the case this time. I have 3 different laptops at home all with EOS. Only this Lenovo with that Realtek driver had the problem. I say had, because it seems to be solved at least for now. I uninstalled that rtw89-dkms-git and then reinstalled it. It didn’t make any difference at first, but after restarting laptop couple of times my wifi seems to be ok. Weird, huh?
I have few questions though. What happens if that 5.16 kernel includes correct wifi driver and I still have that git version installed? Should I remove it later? How do I even know if that new kernel has it?

1 Like

I guess it’s wait and see. I’m just going by what i read on github. If the 5.16 has a kernel module for it then you should be able to remove the rtw89-dkms-git package and it should load on boot and work. It won’t be long now as the 5.16 kernel i think is release date of around jan 9. Whether this happens in the first release or later on is hard to know.

https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers-next.git/commit/?id=e3ec7017f6a20d12ddd9fe23d345ebb7b8c104dd

Edit2: Sounds like it should be included in the new kernel.

Thanks for the information. I will wait for the next kernel then. Because my wifi problem seems to be solved at least for now, I will make this case solved.