SOLVED - After update today, system fails to boot to GUI

At first I was getting stuck on Network Manager Dispatch Services line with a mention that plymouth had started. Because I had installed plymouth during an earlier troubleshooting attempt to get system booted and didn’t think I needed it (I don’t have a splash screen anyway), I removed it.

This got me further into the boot process, but it still halts. I was able to remove plymouth because I can ctrl + alt + f in and remove packages/etc, so network is working fine. I’ve tried systemclt restart sddm but it doesn’t boot me into GUI, even though systemctl status sddm says everything is fine??

journalctl -xe doesn’t seem to show anything indicating a problem, it just doesn’t go any further.

I have really no idea what to check next. I googled the place it was getting stuck before but that didn’t really give me a useful thing to try. Right now it just finished “Started Notify NFS peers of a restart” but I don’t see anything it was starting that didn’t go to started or any of that.

I’m not that proficient with all the troubleshooting commands I need at this point, so I’m sure there is some step I’m missing. I have searched, and it’s possible I missed something in searching for wrong terms/etc.

could be related to your attempt to install setup plymouth… or GPU driver (nvidia?) could be also sddm issue or something in your users desktop setup…

But without any info oin yopur system?
Hard to help :wink:

Thanks, it ended up being the nvidia driver.

I gave up just a little too early, the “new bing” with GPT chat provided me with some additional ideas when I asked the questions there.

I had installed nvidia-vulkan from yay because of an issue with a particular game I was trying to resolve. I guess that didn’t get re-built with the kernel upgrade, so I’m switching over to the proper nvidia driver since the game issues I had (artifacts in both of the Jurassic World Evolution games) did not get resolved, and I just had to use windows to play those with my son.

This was the helpful part of the chat
journalctl -b - p err

journalctl -xe was just too much I think so I missed the important lines, and in this one I saw nvidia mentioned and it was the only thing tha tmade sense as all the other issues noted in that error log didn’t seem like something that would halt boot.