[Solved] After update Plasma autologin will not work

So did updates, rebooted for new kernel, I get my mouse cursor and that’s it. Drop to terminal and turn off autologin, reboot. Sddm comes up as normal. Able to login without issues. Re-enable autologin and reboot. I get my mouse cursor and that’s it. Obviously minor issue since everything works fine if I DON’T have autologin information in the sddm config, but gut instinct says it must be sddm (sddm (0.18.1-3 -> 0.19.0-1))…anyone else have this?

No issues for me, what are the logs saying?

Nothing that means anything to me. But this is the only difference I see from when I attempt autologin to when I log in manually:

Nov 03 19:36:47 reaper sddm-helper[1228]: PAM unable to dlopen(/usr/lib/security/pam_tally2.so): /usr/lib/security/pam_tally2.so: cannot open shared object file: No such file or directory
Nov 03 19:36:47 reaper sddm-helper[1228]: PAM adding faulty module: /usr/lib/security/pam_tally2.s

Verified that module does not actually exist, but I have no idea what it is, what it does, or what package would install it.

PAM tally2 has been depricated, hence this message.

See arch bug report with a similar issue.


Check for any .pacnew files in /etc/pam.d as per the bug report.

Never used autologin myself, given manual login works autologin might well be configured or hard coded to use PAM tally2. Dunno.

As for what PAM is …


PAM provides a framework for system-wide user authentication
1 Like

Same issue here.

Oh no, I know what PAM is, just had no idea what that module is.

Also, no pacnew files in /etc/pam.d at all.

Ok, so to test, I downgraded back to sddm 0.18.1-3, and no more errors about pam_tally2 and autologin is working. I’m just going to add sddm to the ignorepkg for a while, wait until I see a new build and try again. Seems best way to me.


I deactivated autologin in my sddm.conf and everything is back to normal again (except autologin)

This indicates that the updated SDDM no longer uses the depricated PAM modules, so presumably /etc/pam.d/sddm-autologin needs to be updated too.

SDDM doesn’t provide a default PAM config, it is up to distros to provide it.

Someone should probably raise this upstream and get the sddm maintainer to update /etc/pam.d/sddm-autologin to work with the new PAM stack.

Or you could raise it as an issue on the Arch bug tracker and get it fixed.

This is not a solution.


This guy says changing Session= to Session=plasma.desktop in /etc/sddm.conf.d/kde_settings.conf fixed his issue.

It’s not a solution, but after being in the true Arch community for like 10 years, It’s a solution I’m willing to deal with. I won’t touch Arch community anymore, not even to open a bug report. Even bug reports they’re far too uppity and full of themselves to bother dealing with. Someone else will see it and report it and it’ll get fixed eventually, I’m totally fine waiting. Far better than having to interact with that type.

I BELIEVE that’s what mine already had (I’m not on that machine currently), as I had done the “sync settings” from systemsettings so that sddm would use my choice of mouse cursor.

edit - just checked, and just had plasma not plasma.desktop, but other than that, I did have that in my kde_settings.conf file. Not that it matters as it works with the new sddm package.

Package sddm up to 0.19.0-2 today, testing it to see if it’s fixed.

edit - Seems package -2 fixed.


A noob question…
How do enter my pc to apply these changes if it do not pass the black screen and the cursor?

ctl-alt-F2 to get to a terminal, log in there. Assuming you’re using NetworkManager you should probably have a connection (verify with ‘ip add’) and then just go ahead and do a ‘sudo pacman -Syu’ or however you prefer to update.

1 Like