Snapper takes always 2 snapshots per hour

I have snapper installed but no snap-pac. My understanding is that when having installed snap-pac there are pacman hooks so that one has two system snapshots when pacman runs. One before pacman does something and one after pacman has finished its action.

But for the hourly snapshots there are also 2 snapshots which I don’t really want to have, especially when snapshotting for example /home.

How can I configure snapper accordingly?

If you don’t want timeline snapshots for a config you can disable them. In btrfs assistant or in the config file.

That being said, it should only be taking one snapshot per hour for each config. If you are getting two, you probably have something wrong.

Thanks @dalto . I have difficulties with the snapper wording.

There is (if I understand correctly)

  • Enable timeline snapshots which if enabled takes care to take 2 snapshots each hour.
  • for systemd snapper timeline enabled which takes care that snapshotting does happen each hour.

So I have set it now to this

This is a config setting that determines if timeline(hourly) snapshots should be taken for each config.

The service associated with this timer reads the config files and takes the hourly snapshots for configs that have it enabled.

If were getting 2 per hour I wonder if you have the snapper jobs running in both the cron and the systemd timers.

Ok. From your reply I take I have to tick both Enable timeline snapshots and Snapper timeline enabled as you showed in your example.

From the installation of snapper I got /etc/cron.hourly/snapper and /etc/cron.daily/snapper.

Yes, you are right. I enable the timers also in systemd as I was tempted to do so because the snapper package delivered all those things.

So this means is is probably best to delete those timers, namely: snapper-timeline.timer and snapper-cleanup.timer.

snapper supports both cron jobs and systemd timers to run it’s scheduled jobs. Generally you only want one of those running. It has been so many years now since I have run a cron I often forget that some people still install one.

If you are running the cron jobs, you should disable the timers

Yeah, that’s what I did because otherwise I had to delete those files in cron.{daily,hourly}

1 Like

Wouldn’t it be better to make the cron functionality optional during the installation in Calamares, so that you don’t have to uninstall cronie after the installation (as I do)? That would be more in line with OpenSUSE … :smile:

We don’t install a cron during the install.

Sorry, dann habe ich da wohl was mit einer früheren Installation verwechselt. Damals (muss schon Jahre her sein), hatte ich wohl auch noch Timeshift installiert. Womöglich kam das daher. Ok, sorry nochmal, alles gut.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.