Snapd installed by default?

I have a pretty much brand new system but when I ran the “yay” command I found a line saying “Flagged out of date AUT packages: snapd” (see screenshot below). However, when I ran “snap list”, nothing came up; when I ran “snap version”, it shows 2.58.3-1. Is snap installed by default? Thanks.

Absolutely not installed by default.

In fact, we don’t install any AUR packages.


snapd is not even the regular repositories.

it is in AUR.

The installer won’t install anything from AUR.


1 Like

The screenshot is messed up for me. Only green vertical bands. Is this for me or for anybody else?

But why in the world with an Arch-based distro would “snap version” give anything other than “command not found” or “no such file or directory”? That doesn’t come from a “pretty much brand new” system.

1 Like

Did you happen to install pamac-all to this “almost” new system?

1 Like

sorry, I just re-uploaded the screenshot with png format, didn’t know jpg doesn’t work on this website. Please review and let me know if there’s a solution. Thanks.

sorry, I just re-uploaded the screenshot with png format, didn’t know jpg doesn’t work on this website. I just ran the history command, didn’t run any command like “pamac-all”. Please review and let me know if there’s a solution. Thanks.

You might have to sit around to see if there will be another maintainer for “snapd”. Otherwise maybe you should install Ubuntu or another Linux distro that deals with that more easily.

There’s nothing else to do with an outdated package from AUR except uninstalling it. If you feel you really, really, really need Snaps on an Arch-based distro, then we will just have to wait until the idea becomes sound enough and somebody or some group gets around to maintaining it again.

Being a bit sarcastic, sorry, but the screenshot you gave out speaks for itself.

Another thing is that probably JPEG files load on this site, but yours might have warped or something while it was uploaded. :person_shrugging:

1 Like

Do you really need this package at all?
You don’t seem to have installed any snap applications.
If you don’t need it you could uninstall it if you wish (that is if nothing else in your system is dependent on it).

You could check with pacman -Qm to see if you have installed anything from AUR which might have snapd as dependency.

1 Like

Please read:

(Must read further down, more than what’s shown here.)

1 Like

The solution would be to remove it.

Why/when did you install snapd in the first place?

If that was installed by default - please check the integrity of your installation media to the checksum on the site, you’ve got a hacked iso. Where did you download it from??

If you are curious you should be able to determine where snapd came from.

First check if anything depends on it with pactree -r snapd

If there is nothing there, search /etc/pacman.log for the first occurrence of of “snapd” and see what else you installed around the same time, maybe that will help remind you.


I was merely taking a stab at what could have included snapd as a dependency. Pamac is a very likely culprit. Pamac-all is a gui package manager that would have been installed with “yay -S pamac-all.” As others have already replied, snapd is not part of the default install. Therefore, it was installed by something you added to your system.

1 Like

I don’t need snap at all. How do I uninstall it completely? Thanks.

Please see screenshot. How to further diagnose?

Plz see screeshot after running “pactree -r snapd”. I don’t think I installed pamac GUI…but when I ran “which pamac”, the system returned “/usr/bin/pamac”. How should I further dignose how pamac and snapd were accidentally installed?

Right. So you installed pamac-all at some point in the past. This, in turn, installed snapd as a dependency.

If you search you pacman log for it you should see it getting installed.


Oops! There it is.

You can try just removing those:

yay -Rns snapd libpamac-full pamac-all
1 Like

Thank you. How should I further dignose how pamac & snap were accidentally installed? I cannot launch the pamac, can’t even find it…if it (GUI) was actually installed.

Sometimes it is not explicitly named “Pamac” in the GUI, it can be named “Add or Remove Software” or similar. Open your software center and check the “about” option to reveal what software it is.