Smb and filemanager


I must have done something wrong or I am missing something. I installed endeavor and for the first time I cannot access my smb/cifs shares on my NAS. They show up in the file manager but when I try to connect to them I get a cant get share list from server? The odd thing is I can connect to the via cmd line or by using a fstab statement. So I know smb is working but why cant I access with file manager? I tried on another machine and a VM same result. I installed manjaro and it works, so there has to be something missing?



What file manager are you using? What happens if you attempt to access it via the file manager’s path e.g. smb://192.168.1.x/sharename/?

I think EnOS comes with these, but make sure you have gvfs and gvfs-smb, if you’re using Thunar you may also need Thunar-volman.

It connects using the path, I am using whatever default install is I am guessing gnome files? yes both of those are already installed. I have never ran into this problem before its strange. exact error that pops up when I click on share is “Unable to access location, failed to retrieve share list from server: connection refused”

I did like this:

Added this to /etc/fstab

//server_ip/folder_share /mnt/public cifs noauto,x-systemd.automount,x-systemd.mount-timeout=30,_netdev,nofail,rw,uid=1000,gid=1000,credentials=/etc/samba/credentials/share,iocharset=utf8,vers=3.0 0 0

This file, /etc/samba/credentials/share contains the user/password/domain info:


Then, secured the credentials file:

# chown root:root /etc/samba/credentials
# chmod 700 /etc/samba/credentials
# chmod 600 /etc/samba/credentials/share

Yes thank you I have done that and it works, I have many directories though and do not like them all mounted, only the ones that I use daily but occasionally I like to grab something from another directory and I use the file manager to access it,

If you don’t want them permamounted, you can add the the share/folder as a bookmark (drag the root directory to the menu on the left side) once you have connected via the path or fstab.

If you’re on Gnome the default FM is indeed Gnome Files (or sometimes called Nautilus). It should have the necessary modules installed by default.

As for why you cannot browse them via the network entry I’m not sure, is it a Windows share? Sometimes those can be a bit tricky.

To be able to browse the network shares, the NAS should have WS-discovery enabled and/or bonjour

What I do is to add all the folders in fstab that I want to be mounted, then I bookmark them from /mnt folder…


I did miss that statement… probably something else then…

Thank you, I guess its just something with this particular distro, I can make do with it as is, just found it bizarre that it did not work as I expected to but I guess every distro has its quirks. Overall I really enjoy enOS and will stick with it, maybe I will be able to browse in file manager in the future. Thank you for all your quick and helpful responses.


I did just notice this not sure its related to my issue or not but when I ran systemctl start smb I got

smb.service: Got notification message from PID 18298, but reception only permitted for main PID 18293

not sure what that means exactley

What happens when you type:

$ smbclient -L ad_ip -U%
Can't load /etc/samba/smb.conf - run testparm to debug it

	Sharename       Type      Comment
	---------       ----      -------
	sysvol          Disk      
	netlogon        Disk      
	IPC$            IPC       IPC Service (Samba 4.13.14-Ubuntu)
SMB1 disabled -- no workgroup available

I get;
do_connect: Connection to ad_ip failed (Error NT_STATUS_NOT_FOUND)

looking that up now

sorry, forgot to mention, you need to replace ‘ad_ip’ and use the active directory IP address there.

Ex: If your smb server has the ip, the command would be:

smbclient -L -U%

Along the command above, these are all the checks I do when I setup a samba ad:

$ cat /etc/resolv.conf
search domain.local
$ host -t SRV _ldap._tcp.domain.local.
_ldap._tcp.domain.local has SRV record 0 100 389 rpi4.domain.local.
$ host -t SRV _kerberos._udp.domain.local.
_kerberos._udp.domain.local has SRV record 0 100 88 rpi4.domain.local.
$ host -t A rpi4.domain.local.
rpi4.domain.local has address

sorry about that…

smbclient -L -U%

Sharename       Type      Comment
---------       ----      -------
config          Disk      
downloads       Disk      
backup          Disk      
movies          Disk      
music           Disk      
playlists       Disk      
podcasts        Disk      
tv              Disk      
rick            Disk      
pi              Disk      
pictures        Disk      
iso             Disk      
homes           Disk      Home directories
IPC$            IPC       IPC Service (omv server)

SMB1 disabled – no workgroup available

If all the tests I suggested pass and still don’t work, I suppose only Dalto will be able to help you…
He usually has an answer for almost everything here…

Different file managers require different supporting libraries to connect to various devices and shares. For example, Thunar requires gvfs:

$ pacman -Si thunar
Repository      : extra
Name            : thunar
Version         : 4.16.10-1
Depends On      : desktop-file-utils  libexif  hicolor-icon-theme  libnotify  libgudev  exo  libxfce4util  libxfce4ui  libpng
Optional Deps   : gvfs: trash support, mounting with udisk and remote filesystems
                  tumbler: thumbnail previews
                  thunar-volman: removable device management
                  thunar-archive-plugin: archive creation and extraction
                  thunar-media-tags-plugin: view/edit ID3/OGG tags

gvfs also has optional dependencies to support more protocols:

$ pacman -Si gvfs
Repository      : extra
Name            : gvfs
Depends On      : avahi  dconf  fuse3  libarchive  libcdio-paranoia  libsoup  udisks2  libsecret  libbluray  libgudev  gcr  psmisc  gsettings-desktop-schemas>=3.34.0
Optional Deps   : gvfs-afc: AFC (mobile devices) support
                  gvfs-smb: SMB/CIFS (Windows client) support
                  gvfs-gphoto2: gphoto2 (PTP camera/MTP media player) support
                  gvfs-mtp: MTP device support
                  gvfs-goa: gnome-online-accounts (e.g. OwnCloud) support
                  gvfs-nfs: NFS support
                  gvfs-google: Google Drive support
                  gtk3: Recent files support

If you install the associated optional dependencies then things will start working.

1 Like

Thank you everyone for your assistance, I still havent got it to work as expected or like the gnome installation (manjaro) sitting right next to this one. I even installed thunar to see if it would behave differently, while I dont get the error when I click on the share, it just hangs it up.


To what? You didn’t mention anything about your system so I assumed you were using the default Xfce.

If you provide more information about your setup (e.g. inxi -Faz) then people can provide more specific help (without guessing or making assumptions).

GNOME uses Nautilus by default, and that still uses gvfs, and gvfs still has a number of optional dependencies as I listed above.

many apologies…

I have tried and had these errors on the following setups

enOS gnome. Lenovo p14s AMD 7
enOS gnome Lenovo t430s intel i5
enOS gnome proxmox VM

and I have installed everything suggested above


Still missing any useful level of detail, sorry. Which packages, what are the errors, is there anything in your journal, what’s different between the EnOS system and Manjaro, …

I am pretty new to troubleshooting so I may not be able to provide what is needed without some instruction. I installed all the dep’s and optional dep’s that were suggested about. Here is the result of journalctl -u smb

Dec 06 12:18:29 fido2 systemd[1]: Starting Samba SMB Daemon…
Dec 06 12:18:29 fido2 smbd[3249]: [2021/12/06 12:18:29.201511, 0] …/…/source3/smbd/server.c:1738(main)
Dec 06 12:18:29 fido2 smbd[3249]: smbd version 4.15.2 started.
Dec 06 12:18:29 fido2 smbd[3249]: Copyright Andrew Tridgell and the Samba Team 1992-2021
Dec 06 12:18:29 fido2 systemd[1]: Started Samba SMB Daemon.
Dec 06 12:18:29 fido2 systemd[1]: smb.service: Got notification message from PID 3255, but reception only per>
Dec 06 12:22:44 fido2 systemd[1]: Stopping Samba SMB Daemon…
Dec 06 12:22:44 fido2 systemd[1]: smb.service: Deactivated successfully.
Dec 06 12:22:44 fido2 systemd[1]: Stopped Samba SMB Daemon.

happy to provide anything else of use.

Both manjaro and enOS I tried to access share via file manager before installing anything on either system as the omv nas is where I keep all my backups etc so I access the shares first thing after doing system update on a new install. So there is not really any difference atm for either distro.