Small help with Timeshift

After the my mess today, where I wanted to roll back one day, I noticed that I had only one snapshot from over a week ago (when I set it up). It seems like Timeshift just doesn’t take any snapshots for me (like I intended to).
This seems very similar to this post Timeshift-autosnap not working with yay update - #7 by DromundKaas unfortunately there is no solution there.

zsh: no such file or directory: /etc/timeshift-autosnap.conf

This here scares me… because I did go through the setup of Timeshift.

IF Timeshift is completely borked, what program do you recommend instead?

1 Like

What says

pacman -Q timeshift-autosnap


Just adding that the settings for timeshift is stored at /etc/timeshift/default.json

Here you go

pacman -Q timeshift-autosnap
error: package 'timeshift-autosnap' was not found

And the default.json says

backup_device_uuid	""
parent_device_uuid	""
do_first_run	"true"
btrfs_mode	"false"
include_btrfs_home	"false"
stop_cron_emails	"true"
schedule_monthly	"false"
schedule_weekly	"false"
schedule_daily	"false"
schedule_hourly	"false"
schedule_boot	"false"
count_monthly	"2"
count_weekly	"3"
count_daily	"5"
count_hourly	"6"
count_boot	"5"
snapshot_size	"0"
snapshot_count	"0"
exclude	[]
exclude-apps	[]

Will change daily to “true” and I prefer to have 3 snapshots stored.

I guess we’ll see tomorrow night to see if the change stuck or not.

You don’t have timeshift-autosnap installed.

It is an AUR package providing a hook which triggers a timeshift’s snapshot to be taken prior to package upgrades.


Also, if you set timeshift to be run on schedule, make sure to have enabled and started cronie.service:

sudo systemctl enable --now cronie.service

1 Like

Thank you for this.

Just my curiosity, do I need the timeshift-autosnap? I thought it was enough to have just scheduled service.

Did not know about the cronie.service so thank you for that.

It is not a must. It is totally up to you.

If you are going to take several snapshots daily and are not a “heavy tweaker” making changes to your system all the time, I would say you will have relatively fresh snapshots to roll back to if/when the need arises.

I have “tweaked” as much as I want. I think one per day should suffice.

Thank you for this.

I want to see if enabling cronie.service fixes my problem. So if I see a new snapshot tomorrow, I’ll mark this as solved :slight_smile:

Have you already set up Timeshift?
You could do it using the GUI. No need to edit the file directly.

And good luck!

That’s the thing, I had already set up Timeshift, but I got no snapshot. I did that over a week ago and the only snapshot I have, is the one I made.
I did the setup through the GUI, but like the file said, everything was set to “false”.

I guess that was because Timeshift relies on cronie.service to run on schedule.

Check the status of the service:

systemctl status cronie.service

If it is running so hopefully Timeshift will “behave” as it should.

It’s running. Just want to see new snapshot tomorrow before I mark this as resolved :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.