Small fix proposed for /etc/fstab when using btrfs


Trying eos in a Qemu VM, letting the installer use all disk with btrfs, I get in /etc/fstab lines like:

UUID= / btrfs subvol=/@,defaults,noatime,compress=zstd 0 0

Nothing wrong, but the “,defaults” is useless (it is just a placeholder when no other options are set), so I suggest this instead:

UUID= / btrfs subvol=/@,noatime,compress=zstd 0 0

Same for similar lines.


1 Like

It is true that it doesn’t do anything but it is also a fairly common convention to include it.

I took a look at what other distros do, some include it, some don’t. In my limited sample there were more who didn’t include it.


Also, welcome to the forum!

a welcome from me too @Didier nice to see you welcome us with a little challenge :enos:

Nothing major indeed. Thanks for your welcome. I used eos to test a script that I recently made available: (yes one more, but my justification is that it is fully accessible to blind folks, which matters for the Slint distribution that I maintain). @dalto: in addition, btrfs-assitance is included in Slint by default, congrats for it!

Oh, and I am favorably impresses by eos :slightly_smiling_face:

Sorry for the off-topic, take care


interesting to see slint there is a number of users asking for impared vision support all the time.
Now i have something else to link them too!

Indeed, the option defaults is useless for Btrfs after my testing, but it is for ext4.

Mount Options


Use default options: rw, suid, dev, exec, auto, nouser, and async. These are not Btrfs-specific.