Slow startup for applications after recent update from gnome fix

Just an FYI after the recent gnome 44 update if some of your application startup times have been long. Removing xdg-desktop-portal-gnome if you have it installed has fixed the issue for me. I am on i3wm not gnome by the way.


That sounds interesting… You mean, you’re running native gnome-apps on i3? May I ask, which ones you like running mostly?

Welcome to this forum! :v:

hey, thanks. I am liking EndeavourOS’s i3wm edition quite a bit. I usually only use gnome apps if i am running the gnome DE. I think when i setup Flatpak the xdg-desktop-portal-gnome was installed by default. Just a suggestion if anybody uses GOG for classic games try out the Flatpak Heroic-games-launcher it is really good.

1 Like

I have the same issue. But I’m using XFCE, it takes about 12 sec to open Firefox. Is it safe to remove this package ?

Same issue here (i3wm) with gtk apps.
e.g. evolution, thunar

removed xdg-desktop-portal-gnome → problem solved

Thank you very much!

I confirm for me also. I’m using XFCE
Firefox was taking more than 15 sec to start now it is back to normal
Thank you

Very funny on monday morning when you press the keyboard shortcut and nothing happens. (to much party at weekend?) After a while you have 20 firefoxes at once ^^

Just in case anyone is curious if it is safe to remove xdg-desktop-portal-gnome. I’m no expert in this matter but i believe if you have the xdg-desktop-portal-gtk package or any of the other backends Flatpak needs everything should still work fine.

1 Like

Same here with XFCE since this weekend :

GNOME apps : Console, Calculator, Archive Manager, System Monitor, Image Viewer (eog)

Encountering this issue, one could study this:

Had this issue. But I was also having issues with link’s opening from flatpak applications (ferdium for my case). As soon as I removed xdg-desktop-portal-gnome links would open immediately and correctly.


Same issue here using i3wm.

Affected applications: Firefox, OBS, pavucontrol

Fixed w/ pacman -R xdg-desktop-portal-gnome

1 Like

I also removed xdg-desktop-portal-kde on my EnOS install with KDE / i3-wm and now FF starts much faster. (I don’t have flatpak installed so it probably isn’t needed by anything else).

1 Like

XFCE : Affected applications: LibreOffice, Element, Qalculate, Normcap

I thank you from the bottom of my heart kind internet stranger. Created an account just to say this, have a good day.

1 Like

I counted the time it took to load libreoffice (47 seconds) and was casually browsing here, didnt expect to find the answer. Wasnt even aware it was a problem, just thought it was normal. Thank you so much.

The topic grabbed my attention as after a recent update the add/remove app program was taking 20 seconds to load. Its still not instant (maybe 5 seconds) I remember it being faster. Think its pamac manager. Should I find an alternative? I’ll aways used pacman.

Also this is the second time the forum has come to my rescue. I had a grub error, after fixing it my system load time shortened, but also, my entire system has been so smooth recently. Qbittorent was freezing my system but even now its snappy and fine. Must have been an update? The performance was as expected of my poor computer but recently its like a rolls royce.

You can disable Libreoffice using Java in Settings > Advanced to make it start much faster. :wink:

Yes I had tried this, also I believe I tried disabling any printer loading settings. This reduced Libreoffice writer load time by about 20 seconds. It originally took over a good minute. Now it loads in seconds. Wonderful.

Not sure if related to deleting the gnome file, but duckduckgo is now refusing to use dark mode. I have dark mode set in brave or to use a theme. Also using dark reader extension. Other pages seem fine.

1 Like

Confirming it worked in MATE desktop also!

how can i uninstall xdg-desktop-portal-kde ? i keep getting this message:

╰─>$ LANG=C yay -R xdg-desktop-portal-kde                                      1 < 10:08:52
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing xdg-desktop-portal-kde breaks dependency 'xdg-desktop-portal-kde' required by plasma-meta
:: removing xdg-desktop-portal-kde breaks dependency 'xdg-desktop-portal-impl' required by xdg-desktop-portal
 -> exit status 1