Slow shutdown/reboot process

Frequently the shutdown or reboot process will take 2+ minutes before it completes. It’ll show a black screen within a second or two of pressing the button and then hang there for quite a while. I suspect there is a process which isn’t shut down, as this doesn’t happen every time. Is it possible to force everything to shut down immediately?

You can use the poweroff command in a terminal.

Yes, 9/10 times I will shutdown or reboot via the terminal, however this does not make much difference (at least not when issuing reboot).

You could remove quiet from kernel boot parameters in /etc/default/grub and regenerate grub.cfg to make boot up and shutdown messages visible. Hopefully it will reveal something about what is holding up the process.

3 Likes

That’s quite useful, did not know this was possible. Thank you!

1 Like

Unfortunately not too detailed, most applications shut down and then it hangs on A stop job is running for Session 1 of User Celty (seconds/1 min 30s) until it hits the timer, at which point it stops for another another three minutes at A stop job is running for User Manager for UID 1000 (x / 3 minutes 30 seconds). Once it hits the 3.30 mark it shuts down/reboots. UID 1000 is my user.

A quick search tells me this is a result of a process ignoring SIGTERM and the end of the timer it issues SIGKILL which terminates it. Is there a downside to setting this timer to something like 5-10 seconds and if not, how can I do that?

It does seem like a bit of a bandaid fix though, so if someone has a better solution feel free to share it.

I have had the best luck using sudo shutdown now or sudo shutdown now -r.

I think there could be many reasons for this. It probably is only one app that is holding everything back.

Sometimes I have had similar behaviour because of some removable disks were not properly removed. And then the disk parameters in /etc/fstab needed changing, which solved it.
But of course you may have some other reason for this.

One thing to try also is installing the LTS kernel and see if it works any better.

1 Like

For me, it is always the emacs daemon, but I developed a work-a-round.

After some more testing, it seems to be Wine causing it (or the League of Legends client itself).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.