Sleep and package update problem


I’ve been using EOS as my primary OS for the last three months and overall I’m extremely pleased with the system. Unfortunately two annoying errors occured out of the blue during the last couple of weeks:

  1. Sleep stopped working on my system
  2. The pacman hook “Reloading device manager configuration” after updating packages exits with an error.

As I am fairly new to debugging on Linux could anyone help me with fixing those two errors?

I had a look at the pacman log but wasn’t able to find a cause for 2).

Thanks in advance!

Tried booting on LTS kernel already to see if this is kernel related?

For the second issue it would need to see the error :wink:

For an introduction on debugging see here:


It’s been a while but since I haven’t resolved my issue so far, I’m following up. I’m still having the two problems mentioned above, 1) sleep is not working, 2) there is an error when pacman is doing the hook “Reloading device manager configuration…”. Switching to the LTS kernel didn’t help either.

udevadm control --reload-rules && udevadm trigger also gives me an error.

Here is my hardware report:

I tried sending the boot log via eos-sendlog but apparently it is too big (~350 MB). I uploaded it to dropbox instead:

I would be great if someone could help me and tell me what other debugging steps to do.

Thank you so much!

Can you share the full error message you are getting when you get errors? There may be something there that gives us a clue as to what the issue might be.

the journal is full of pcieport warnings and bus errors. that’s the reason why the log is that huge… if this massive log spamming happens it will already on its own slow down system and can cause issues on its own…

1 Like

Thank you for your answer. I just opened the file and noticed that too… Is there any way to troubleshoot those PCI errors?

Thank you very much for making me aware of the PCI bus errors. I googled for similar errors and found someone getting similar errors on the Intel X99 platform. I added “pcie_aspm=off” as a kernel parameter to GRUB_CMDLINE_LINUX_DEFAULT which apparently solved my issues. :grinning:

1 Like