Slack for Linux(Beta) doesn't work ( stuck at Sign In Window)

Well, I tried to run Slack natively on my endeavourOS with no success !
I was able to install through yay as its provided in aur .
On launching , It redirects to the Web Browser for loging in . However , slack is stuck at the login window when the browser opens it as xdg-app.
In addition , the official slack website https://slack.com/intl/en-in/ has .rpm (I tried making pkg from rpm but failed at installation), .deb packages and snap store option which I dont prefer .
I have to use Slack in the browser which isn’t so great.
Any help .Thanks .

Id contact Slack upstream and see if they can offer a proper fix, here you may get a workaround or 2 but the devs know their program best
if you need advise on how to do thisl ill try my best to walk you through it

What do you mean by “stuck” here? Which browser is it loading in? Do you have browser extensions that are blocking resources?

The browser actually opens Slack after giving correct credentials but still Slack is ‘stuck’ at the login Window
image

Yes please !

Give me a bit but will post it here soon, using the phone for a keyboard at the monent but will ttry post how to soon
sorry if it takes me a bit, will probably just post links for now, this phone is annoying to use

Just want to confitm you have been through this?

Can’t replicate the issue here. I sign into Slack in the browser, it asks me to select a workspace, then the browser prompts to open the Slack application and it loads correctly.

1 Like

Same here, zero issues installing or logging in

1 Like

Could you try using another web browser? I am guessing you are using something Chromium-based as you mention xdg-app so perhaps set your default web browser to Firefox and try again?

1 Like

What happens when you click the “Sign In to Slack” button when you’re signed in in the browser?