Skanlite: symbol lookup error: /usr/lib/libsane.so.1: undefined symbol: libusb_set_option

This was working at one point in time. Curiously, it seems that the symbol is there:

nm -D /usr/lib/libsane.so.1 | grep libusb_set
                 U libusb_set_configuration
                 U libusb_set_interface_alt_setting
                 U libusb_set_option

Any ideas how to get this working?

Have you tried reinstalling sane, xsane and libusb?

Yes, multiple times. Same result each time. It’s got me stumped.

[phil@venom ~]$ yay -S sane libusb
Sync Dependency (2): sane-1.2.1-5, libusb-1.0.26-2
warning: sane-1.2.1-5 is up to date -- reinstalling
warning: libusb-1.0.26-2 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (2)  Old Version  New Version  Net Change

core/libusb  1.0.26-2     1.0.26-2       0.00 MiB
extra/sane   1.2.1-5      1.2.1-5        0.00 MiB

Total Installed Size:  18.49 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] 
(2/2) checking keys in keyring                                                                                    [--------------------------------------------------------------------] 100%
(2/2) checking package integrity                                                                                  [--------------------------------------------------------------------] 100%
(2/2) loading package files                                                                                       [--------------------------------------------------------------------] 100%
(2/2) checking for file conflicts                                                                                 [--------------------------------------------------------------------] 100%
:: Processing package changes...
(1/2) reinstalling libusb                                                                                         [--------------------------------------------------------------------] 100%
(2/2) reinstalling sane                                                                                           [--------------------------------------------------------------------] 100%
:: Running post-transaction hooks...
(1/7) Creating system user accounts...
(2/7) Reloading system manager configuration...
(3/7) Updating udev hardware database...
(4/7) Reloading device manager configuration...
(5/7) Arming ConditionNeedsUpdate...
(6/7) Refreshing PackageKit...
(7/7) Checking which packages need to be rebuilt
[phil@venom ~]$ skanlite 
skanlite: symbol lookup error: /usr/lib/libsane.so.1: undefined symbol: libusb_set_option

I have just installed skanlite (currently booted into hyprland):

Uninstall everything and reinstall? Other than that stumped as working here.

Wow. Figured it out. It seems that nuitrack left some crap behind in /etc/ld.so.conf.d/ and /usr/local/lib/nuitrack/. I removed both of those and up comes skanlite.

Bizarre.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.