Simple-scan not working

Hi

I have a HP Laserjet M1136 MFP that it did not use for the last three years. It was working beautifully with simple-scan at that time.

Now, I set up again with hp-setup and reinstalled the simple-scan package.

On launching this latest application, the hp printer appears, the top left indicates scan, it says ready to scan, but when I launch it it says: failure, impossible to connect to the digitalisation peripheric (in French)

I am out of my mind.

It looks like the simple-scan pkg. is missing some dependencies to be installed, for it to work properly.

You can check them out here…
https://archlinux.org/packages/extra/x86_64/simple-scan/

…and install the needed ones by running this command:

sudo pacman -Syu --needed colord-sane dconf gtk3 libgusb libhandy sane

I did it. Some dependencies were indeed missing. However, the same error message appears when I click on “scan”

Did you reboot afterwards?

I also have an HP device.
I start simple-scan once as root so that the scanner can be found.
So that no file permissions are broken it is a simple thing with this command.

sudo -H simple-scan

I think it would also work with gksu or for kdesu depending on the desktop type.

To no avail. I also checked all dependencies for hplip.

Did you add your user to the scanner group ?

grep scanner /etc/group

if not :

sudo usermod -aG scanner roger64

(if roger64 is your user name)

roger@roger-lenovo ~]$ grep scanner /etc/group
scanner:x:96:roger

It was already in place in the group

I launche xsane which provides a little more information. It detects the printer but says there is an I/O error on this peripheric.

Maybe you’ll get more infos with the scanimage test :

scanimage -T

Give skanlite a try see if this works with your printer/scanner. I’ve got an old usb HP6200C flatbed
scanner and it works with it. I also loaded simple-scan up and ran it.It also worked. Is there any HP driver installation that needs to be fixed? I’ve had issues for the longest time with HP and my p1006 laser printer but it works with the HPLIP finally. It required a proprietary HP driver download everytime to get it to setup and work with HPLIP. Everything is good now.

Rich :wink:

I installed skanlite and obtained the same result as with xsane

roger@roger-lenovo ~]$ scanimage -T
Output format is not set, using pnm as a default.
scanimage: sane_start: Invalid argument

I am sorry if this information is already somewhere in this topic, but:
How is the printer connected? USB, WiFi or anything else?

Does it just not work for scanning or can you also not print with it?

I should have begun this way. With hp-setup I used usb. When I tried to print, it declared “ready to print” but I got a printing mistake.

I use the hplip from Arch since the manufacturer has somewhat forgotten it among the Linux distros.

This is the error message I obtained after debogging.

So, printing is still not working?
Is cups installed and running?
You should be able to check that with

sudo systemctl status cups

[roger@roger-lenovo ~]$ sudo systemctl status cups
[sudo] Mot de passe de roger :
● cups.service - CUPS Scheduler
Loaded: loaded (/usr/lib/systemd/system/cups.service; disabled; preset: di>
Active: active (running) since Sat 2023-04-29 21:30:40 CEST; 2h 0min ago
TriggeredBy: ● cups.socket
Docs: man:cupsd(8)
Main PID: 64887 (cupsd)
Status: “Scheduler is running…”
Tasks: 1 (limit: 9358)
Memory: 1.9M
CPU: 25ms
CGroup: /system.slice/cups.service
└─64887 /usr/bin/cupsd -l

avril 29 21:30:40 roger-lenovo systemd[1]: Starting CUPS Scheduler…
avril 29 21:30:40 roger-lenovo systemd[1]: Started CUPS Scheduler.

Have a look here. It looks like you might still be needing a package:
https://wiki.archlinux.org/title/CUPS/Printer-specific_problems#HP

3 Likes

Hi

Indeed that’s the solution I was looking for. This missing plugin. Now simple-scan is working and I have no more an error message.

Thank you very much

1 Like

I’m glad you got it working! :v:

For the record, it would be interesting to know which plugin(s) was missing…