Simple Firewall Installatiion

Does anyone know of a simple firewall that can be readily installed?

I have a little experience with ufw (for debian) … but little seems available for EndeavourOS

riccardo

pac search ufw          
community/gufw 19.10.0-1 [installed]
    Uncomplicated way to manage your Linux firewall
community/ufw 0.36-1 [installed]
    Uncomplicated and easy to use CLI tool for managing a netfilter firewall
community/ufw-extras 0.5-1
    Extra configuration files for UFW

As you can see, ufw is available in the community repos, which is most surely available in EOS. As a general rule, if a package is available for debian, it’s also available for Arch.

ufw and the GUI version gfuw are in the arch community repo.

In the welcome greeter you can install it with one click, then follow this wiki article:

1 Like

Thanks people. I have gufw installed. What’s next to make it start automatically when I boot up??

riccardo

It’s described in the wiki link I sent you.

Hi @riccardo
After you get it set up, on your next boot into the system, run this command to check the status and make sure it is working. “Status: active”

sudo ufw status verbose

  1. open terminal
  2. tip - yay -S ufw
  3. tip no.1 1 community/gufw and enter
  4. open ufw
  5. open terminal
  6. tip - sudo systemctl enable ufw.service

Gufw starts automatic. Start Gufw and where it says Status you will see slider switch, click on it and the 0 will become 1 (enabled all the time) . All the instructions are in the Gufw interface. If you did the commands listed in this thread when you open Gufw the status should show 1 (enabled) .

I tried installing it and it keeps turning off? I uninstalled for now. I’ll have to look at it later.

When you start Gufw and set everything finish it off in terminal as tomkey posted… sudo systemctl enable ufw.service

The Bryanpwo link covers everything.

1 Like

I finally got it working. For some reason it just kept turning off? Finally after messing with it it stayed on and is working.

It did the same for me on vanilla Arch, so I gave up. I use firewalld now.