Shopping: New motherboard without "Secure Boot" and TPM

I am dissatisfied with my current motherboard, a Gigabyte B560M 10th/11th gen Intel board. As mentioned, I’d like to get a board that didn’t have the Microsoft mandated TPM and Secure Boot features, plus I’ve not been able to get this board to properly hibernate, or come out of hibernation.

Any thoughts / suggestions are welcome.

Well only older hardware doesn’t have secure boot or tpm so your options are limited. I mean hardware from at least 10 years ago

Secure boot can be easily disabled in most bios/uefi so that shouldn’t be a problem.
TPM mostly can also be disabled in bios/uefi

Or you can look at coreboot, it is a alternative for uefi, but it doesn’t work on a lot of motherboards afaik

Yea, I pretty much was afraid that that was the case. I still have my Asrock 79 ext4 with a Xeon E2650 and 16gb DDR3, still a formidable machine at 12 years old.

There’s still the issue of not hibernating with this Gigabyte B560M board. Simple solution is to repurpose to take each others place in my home network.

Just displaying my (probable) ignorance here - but why do you want it to hibernate? It has always seemed to me that power-saving is sufficiently advanced now to make ‘leaving it on’ a reasonable thing to do - and startups times are so quick now as to make hibernation startups little quicker than a cold boot, even including loading up some apps. IS there some advantage I have missed?

I’m glad you asked, made me do some further checks. Turns out- using a Kill-a-Watt meter shows that the B560M motherboard is only drawing 57W idling at desktop. That’s about a 3rd of what I expected. This board boots slow anyway, for reasons unknown; the boot process is further slowed by the decryption process.
I guess I could overlook the unnecessary use of 57W 24/7, but then I haven’t solved the mystery of why the board won’t hibernate. The other desktop computers in the household hibernate with no problem.

What does the meter say about a hibernating system’s power draw? Not to mention, 57 sounds a bit high to me, assuming HD spin down and and screen sleep etc…

I guess I should double check my systems with one of those meters - as I generally keep them all up - though only the ‘mirror’ machine NEEDS to be up 24/7! Of course, the media server is easier that way too - and machine life expectancy seems to be enhanced by avoiding power down… I’ve had only one actual system ‘death’ since 1987, and that was a C64 that was always powered down!

The machine won’t hibernate, which is one of my main reasons for this thread. Here’s what happens: the power management setting is set to hibernate after xx min.s, the machine actually does power down, but then within 30 seconds it powers back up again. I have tried every conceivable setting in the BIOS, none of which make any difference. My other desktops will hibernate without issue…
Perhaps I should open a ticket with the manufacturer, the board does a a 3 yr. warranty, FWIW. However, I would not RMA it, would only get a banged up used board for replacement.

Just checking: have you set it up correctly, swap partition/file, kernel parameters etc. ?

what DE do you use?

It seems to me that there is some sort of trigger that wakes the pc within 30 sec. could be a mouse or keyboard, disk activity etc

I don’t use hibernate myself, pc boots fast enough, so i don’t see the point but you do so it is a valid issue

What is de hardware/DE of your other desktops? can’t compare apple with pear so if those are exactly the same then there is a problem with this pc only

there’s also chance this is a conflict with screen saver time, or power settings

There is a swap partition, encrypted. I have not manually set any kernel parameters…

This machine and all my other desktops & laptops run Mate as the DE.

I think you could check cat /proc/cmdline to see if there is a resume=UUID=xxxx-xxxx.xx...... (or something similar) in that line.

1 Like

All I get returned is:
~$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-6.1.0-13-amd64 root=UUID=7ce08319-0d26-4b81-a23f-ff60a0a4cba1 ro quiet cryptdevice=UUID=13c483f5-1f4b-4b8c-a1b9-d676432e60ab:luks-13c483f5-1f4b-4b8c-a1b9-d676432e60ab root=/dev/mapper/luks-13c483f5-1f4b-4b8c-a1b9-d676432e60ab splash

You don’t seem to have resume “enabled” so hibernation is not set up on your system.

I have not worked with encrypted swap partition and hibernation so I am not sure what exactly need to be added in your case.

Perhaps you could create a new topic with a descriptive title for setting up hibernation with encrypted swap device.

Well I swapped locations with this and my other desktop, the other desktop being comparable. This will sound weird but…this desktop is now “sleeping” properly in the other desktop’s old location. The “other” desktop is now not sleeping, in the location that the desktop(post topic) originally was in. I don’t get it, same electrical circuit, same type surge protector. ???

Is one location more exposed to a major roadway nearby? I have had oddball phenomena from passing buses, taxis, cop cars etc. One thing that used to happen was random doorbell rings (wireless bell) and TV channel changes - from such things as the device that buses use to influence the lights to change in their favour, and strong RF sources. Perhaps your system in one location simply picks up something that ‘wakes’ it…

Sleep aka suspend to RAM ?


Hibernate aka suspend to disk?

For the latter, I couldn’t see that you had any resume= parameters in your kernel boot line so I don’t understand how that would be possible at all.

For the former, I have no explanation how changing the the location of the machine would have any effect but judging from the post above … :thinking:

No, not within a mile of a highway, no external or extraterrestrial electronic or electrical sources…that I’m aware of. As a test I may construct a Faraday cage around the computer, maybe some tinfoil will do

Regarding the 2nd machine that wasn’t suspending/sleeping/hibernating properly- I found some ACPI settings in the BIOS that needed to be selected. This machine sleeps!

1 Like

Glad you got it! Leaves me still wondering why a relocation changed it, but a fix is a fix!

1 Like