Sh: line 1: command not found after new installation

Hello! I just finally installed EndeavourOS communinty edition with Sway and tried some basic commands. Basically anything other than changing workspaces or direct messages to sway don’t work. For example $mod+Shift+c works but $mod+d does not.

I got into tty and copied the default configuration into ~/.config/sway/config and it seemed to work. I managed to move the i3bar and changed the default $mod to Alt instead. But not $mod+Return or dmenu so I can’t open any program or terminal.

After logging Sway I saw this:


Sorry for not uploading a screenshot, I do not know how to screenshot the tty yet.

So here’s what’s happening: the Sway configuration works but no command is found.

sh: line 1: dmenu_path: command not found
sh: line 1: dmenu: command not found
sh: line 1: foot: command not found

Could it be a PATH problem? Did EndeavourOS it install with a broken configuration? Thank you!

Well, far easier than that. Neither dmenu nor foot was installed. I remember I chose to install only the bare minimum in calamares so I guess it’s just my fault? I will try and reinstall to get more packages.

In case someone else happens to stumble into the same problem:

sudo pacman -Sy dmenu

and now you can access your programs with $mod+d as configured in ~/.config/sway/config if you copied it from /etc/sway/config.

You might think about take look at

(1) eos sway use wofi
Think you get my point .

No, sorry I do not get your point.

I haven’t seen the EndeavourOs Sway github before and I see now which programs should work out of the box. The problem was that after I installed the community edition none of the programs listed in the sway community edition github worked as none were apparently installed, and I did not see the github linked anywhere during the download or installation process.

I “fixed” my problem by reinstalling the OS and now it looks like its working even though I am encountering other problems aswell. I will open other posts for these issues but someone else might still encounter whatever happened to me in this one.

Happy it work better for you after re install.

1 Like

You probably remove more than you thought. If you can remember what you remove ? I be interested to know . :pray:

I wish I could tell you exactly what it was but I remember selecting only Base devel + Common packages. The only thing I did differently was updating and adding more mirrors, and running sudo pacman -Syy before starting calamares, which I did not this time around. Other than that, my procedure was exactly the same and with the same ISO.

1 Like

could it be you do not used the latest ISO? because on Atlantis and Atlantis neo releases you would not be able to unselect any sway related packages. It shows only common base system packages and in addition, options to enable printing and adding kernels.

1 Like

I downloaded and mounted the ISO on monday the 17th. I believe I only updated the mirrors and the sudo pacman -Syy before starting calamaris. It might’ve installed incorrectly because I installed it multiple times trying to figure out efi boot, and also maybe it could not fully wipe whatever was left of the last failed installs. Since everything worked well afterwards I guess the error was on my part, eventhough I am unsure of what happened.

The only clear thing is that reinstalling fixed this issue. I have now got the documented programs, themes and scripts. I configured it a bit, fixed up my efi boot order and grub. Everything looks and works well.

this is useless on the live session it is a fixed system :wink: and it will not effect the install process as we do install from scratch on target same as you would do on pure arch.
Only updating mirrorlist will get copied over to target to be used for installing packages.

1 Like

That is really good to know! Thank :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.