Several things with sudden onset, network manager issues and display stuttering mainly

Hello! Sorry for how vague this will be initially, I’m just not sure what to look at and all my attempts to search for similar issues have been stonewalled by sorta similar but very different problems.

I updated my computer yesterday, though I think the issues started prior to that. I don’t remember the exact timeline. I have been using this computer fine for almost half a year now, and I didn’t make any recent changes to main system settings or change any large software. I’ve added some mods to valheim via r2modman, and that’s about it.

The first issue is that connecting to my wifi through the gui in the task bar results in it stalling on seeking authorization. I manage my wifi and there has been no changes to it, and none of my other devices have trouble with it. If I use the terminal and try to connect with nmcli -a connection up network-name it connects as soon as i enter the password. I’ve tried restarting the computer, restarting the network adapter, i’ve updated the system, and i’ve tried forgetting and readding the connections.

The second issue is my second monitor has started having weird optical glitches. It flickers every once in a while, and if I have something move across the screen it jumps back at regular intervals like a two steps forward one step back type thing. It seemed to get a little better but not stop if i made that monitor my primary monitor, but otherwise I don’t know what to test or try for that.

Theres been a couple other gripes here or there, but i’ve either found solutions or they’re easy enough to ignore. But these two are more annoying. I struggle to find anything other than refresh rate for the display issue. But I’ve tested with all available rates. And all I find with the network issue is different behavior like nmcli not working as well.

If anyone has ideas I’d really appreciate it!

Hi @AvianAnalyst post some system info and people will be able to help you much easier.

In addition, try reseating cable, or if possible try another cable.

Hey thank you for this! I’ll try to get that up, although I’m having worse different issues now. I came across A Complete Idiot's Guide To Endeavour OS Maintenance / Update / Upgrade and realized I wasn’t doing full updates. So I tried to follow it.

I made it most the way through yay without issues, I had an error that some things failed to install at the end though. (I don’t have access to what those were, but i know one was some sqlite package)

Then I sorted through the pacnews/pacsaves, but I think I messed something big up. I started getting a user id doesn’t exist in passwd db error (i dont remember exact wording), and probably stupidly, I restarted the computer to try to get to a fresher state. Now when my computer turns on it goes to a black screen after grub and doesn’t do anything else. I do have a mouse cursor, and I can switch to a terminal and get a login prompt.

I can’t login though, and I think it’s because I don’t remember my username right. I don’t know if there’s a way to check this? Or if it’s broken related to the issue I had immediately prior to rebooting.

I should be able to boot to a previous point in the system as I have i think timeshift set up (i have something I just don’t remember which option I went with). But between work and having a bluetooth keyboard as my main keyboard I haven’t been able to try yet.

I’m not sure if i should:
A) Make a new post about getting back into my computer to get syslogs and then coming back here
B) Jump straight to restoring a previous snapshot
C) Something else?

I can try this, but the glitches don’t happen universally. It happens on multiple applications, but not on the desktop or my terminal emulator (kitty). Obviously no harm in trying once i’m back in, but I’m just not optimistic :stuck_out_tongue:

Ok, the problem was my account line got deleted from /etc/passwd, but i was able to recover it and so far my system is working the same.

Here are the logs @smokey suggested I add

ok so everest (modded celeste) and vesktop (modded discord) both have the flickering problems. and they both depend on lua-lsqlite3 which the source code in the package fails checksum validation. idk if that could be doing something? While they both have graphical issues (regardless of what monitor theyre on) they are different. celeste has a constant flickering. discord has sections or the entirety go black sometimes. clicking or mousing over it brings it back. it also has some sort of screen lag where what its displaying jitters back and forth in time. but celeste doesn’t seem to have any lag or skipping

Ok, it:s that the new version of KDE changes the default to wayland instead of x11, and wayland apparently doesn:t play well with Nvidia. I have my computer automatically login, so I didn’t have the chance to select it and it was an invisible change to me.

Logging out and logging back in under x11 has fixed the screen flickering, and the gui wifi management.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.