Setting up LightBurn

So I have a laser engraver as I mentioned in the Latest Purchase thread, however I can’t get the software to work. The computer isn’t seeing the laser, and looking at their site, it says:

  • Open a terminal and run the following command:
  • sudo adduser $USER dialout && sudo adduser $USER tty
  • IMPORTANT! Log out and log back in (this refreshes the permissions we just added)

Obvious or at least semi-obvious, adduser isn’t a command in Arch, and using useradd gets back an error message that the user already exists.

I guess my question is what are they trying to do here, and how do you do it on an Arch based system?

Add your user account to the groups tty and dialout

sudo usermod -aG tty,dialout $USER 

if one groups groups doesn’t exist you can add it with:

sudo groupadd groupname
1 Like

Well, the good news is those commands worked, the bad news is that the computer still won’t talk to the laser. We know that the cable and the laser are good as we were able to talk to it using my husband’s Mac, but no dice over here.

I don’t have much experience with that kind of device.

It is possible that whatever you are trying to access uses different groups or some type of udev rule.

Is the kernel module loaded for that device? Maybe this is helpful or you already looked at this?

Missed that. Might work, but seems like it’s just hard to get it to work on Arch systems. I actually got it working by setting up another spare computer with Linux Mint Debian edition, so I suppose I solved it? Is it actually a solution when you give up and find a different way to do it?

Yes - sometimes the solution is to use a supported distribution - but in this case you should be able to do it - just use the uucp group on Arch based systems - I don’t know why - I don’t even know why I know - my head is filled with information which pop out at the right keyword - in this case dialout