Setting max cpu frequency

I was trying to set the max frequency for my CPU, and following the arch wiki I used cpupower, now the wiki says that the intel_pstate driver only supports performance and powersave governor. There is a way to use the frequency setted by cpupower?

Did you try this part:


To set the maximum clock frequency (clock_freq is a clock frequency with units: GHz, MHz):

# cpupower frequency-set -u clock_freq

Yes, but after the reboot, the frequency returns to the factory value.

I am not at my EnOS box right now (and I don’t have cpupower installed) so I cannot check but did you look into /etc/default/cpupower to see if some variable could be set to performance?

The configuration file for cpupower is located in /etc/default/cpupower . This configuration file is read by a bash script in /usr/lib/systemd/scripts/cpupower which is activated by systemd with cpupower.service . You may want to enable cpupower.service to start at boot.


You could try this: in /etc/default/cpupower change the following line:

Then enable and start cpupower.service in one go:
sudo systemctl enable --now cpupower.service

Reboot and check.

Thank you, it worked. :grinning:

1 Like