Setting correct PATH (Rust Cargo)

I was installing this website-downloading software, suckit.
Its programming language is rust, so I proceeded to install the package.
Following the instructions, I installed the software with a
cargo install --git

However, after compliction of installation, the following message was prompted

Installed package suckit v0.1.0 ( (executable suckit)
warning: be sure to add /home/user/.cargo/bin to your PATH to be able to run the installed binaries

Not being familiar with the PATH function, I followed the wiki and an online guide to edit my .bash_profile, so that it would read

# ~/.bash_profile
[[ -f ~/.bashrc ]] && . ~/.bashrc
export PATH=$PATH:~/.cargo/bin/

#if [ -z "$DISPLAY" ] && [ -n "$XDG_VTNR" ] && [ "$XDG_VTNR" -eq 1 ]; then
#  exec startx

However, that would not work.
If anyone could point out where I am making some mistake, that will be very much appreciated.
Thank you in advance!! :slight_smile:

Consider this a learning opportunity and I am not trying to be snarky here, just the EndeavourOS way.
“A terminal-centric distro with a dynamic and friendly community in its core.”
Pointing you in the right direction for you to do some research will help you more in the end than just saying “Do this, then do that” Trying is learning.



Thank you very much!
In the end, running export PATH=$PATH:~/.cargo/bin/ in the terminal did it, and as per the guide you linked, I saved the save command in .bashrc as well, to keep it in new terminals.

I deduce my error was that I was not opening new Terminal windows after setting the variable, therefore it was not being read and applied?

1 Like

As far as I know ~/.bash_profile is read only by login shells, so opening a new terminal window (i.e. starting an interactive shell) wouldn’t have worked. You could have, for example, run su -l [username] to start the shell as a login shell.


Thank you very much, this explains why it would not work instantaneously!!

1 Like