Set higher than 60Hz refresh rate Kwin

Hello folks,
I have two ThinkPad laptops, both with 120 Hz IPS panels.
On both I have installed EOS with KDE. So far, so good.
Now, the issue I have is that KDE Kwin doesn’t detect the higher refresh rate.
Gnome, on the other hand, easily detects and use the 119 or 120Hz refresh rate, so I know that the panels I’ve upgraded to are sending the correct EDID.

What I tried.
First I ran cvt 1920 1080 to find out the details of actual display mode for X11.
Created a new xrandr modest, and forced it to use with xrandr.
Well, screen flickered a second and finally the image and graphics were smooth.
In my ~/kwinrc I set up MAXFPS=120Hz and all.
Also, created a 10-modeset.conf in my config. Save and reset and the new refresh rate doesn’t show up and here is where I am stuck.
What I did wrong? Anyone can point me in the right direction?

PS Found out that this a ancient bug and is still to be addressed. People nowadays are running better screen with over 60Hz. It’s time to address it, don’t you think?

Hi there!

Did you remember to set the RefreshRate=120 ?

kwinrc is in ~/.config/kwinrc and not ~/kwinrc

Edit ~/.config/kwinrc

Add under last line of this header:



You can also try using: arandr

Hope this helps.