Serious Lag in LibreOffice

LibreOffice applications installed through the Arch repos lag horrifically for me. Writer lags when scrolling through even quite small documents, and Impress is borderline unusable when any images are dropped in.

This issue still occurs after renaming ~/.config/libreoffice, and it also occurs when running LibreOffice under a new user. The Flatpak doesn’t lag, but it’s got its own problems. Is anyone else experiencing this? I’ve also tried just about all permutations of the relevant settings available in LibreOffice: antialiasing, hardware acceleration, and opencl settings don’t seem to make a difference.

What’s the output of:

inxi -GS

Also, depending on your DE/WM/WC, you could try:

sudo pacman -Rs libreoffice-fresh/still && sudo pacman -S openbox picom libreoffice-fresh/still

In the command above, replace “libreoffice-fresh/still” with either “libreoffice-fresh” or “libreoffice-still”.


Log out, launch Openbox, launch picom, launch LibreOffice, and see if there are any differences.

Hi there, thanks for your reply. This is the output of inxi -GS:

System:
  Host: Endeavour-Lab Kernel: 6.9.2-arch1-1 arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: EndeavourOS
Graphics:
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
    v: kernel
  Device-2: Logitech BRIO Ultra HD Webcam
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu
    resolution: 2560x1440
  API: EGL v: 1.5 drivers: radeonsi,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.0-arch1.1
    renderer: AMD Radeon RX 6800 (radeonsi navi21 LLVM 17.0.6 DRM 3.57
    6.9.2-arch1-1)
  API: Vulkan v: 1.3.279 drivers: radv surfaces: xcb,xlib,wayland

Also, yea, running in openbox there’s no issue at all (at least with writer).

Okay, log back into Plasma, but this time, select x11 and test LibreOffice again.

I don’t think Plasma is the issue, nor LibreOffice - just Wayland.

If things work well in Plasma x11, you can uninstall Openbox with:

sudo pacman -Rs openbox picom

I just stumbled across a reddit thread about this issue from a few months ago: the workaround there (launching libreoffice with SAL_USE_VCLPLUGIN=gtk3) seems to fix the problem.

I just checked and you’re right: there is no lag on X11.

2 Likes

When it comes to regular apps - so, excluding games, IDEs, etc. - if you have performance issues, it’s usually either Wayland or Nvidia. In your case, you don’t have Nvidia, so Wayland it is.

So, if you ever run into any other performance issues while in a Wayland session, just switch to x11 and it will probably disappear.

2 Likes

Chiming in on this, - had to go back to X11, app rendering and performance in LibreOffice and Steam was just a nightmare. There might be some flags possible to set, but overall, the experience remains better on X11 for me.

2 Likes

I have no desire to use Wayland, except for playing with Hyprland, which even though I have an Nvidia card, works just fine with no extra tweaks. I mean, my theme doesn’t look right in some apps, but it’s snappy and pretty overall.

Installed it on a whim and the default config worked just fine.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.