"Segmentation fault" when I try to opening KDE applications

Hi, since yesterday I have this strange problem with KDE applications, suddenly almost none open anymore. When I try to open via terminal (I had to install Yakuake because Konsole doesn’t open anymore).

I’ve had the problem since yesterday and I went to sleep without solving the problem, this morning I woke up and the applications still wouldn’t open. I tried to see if there were any updates and I updated (glibmm and libpulse) and suddenly the applications suddenly start opening again.

But after a few hours, the problem returned

[salvatore@Salvatore-MSI ~]$ konsole
Segmentation fault

This also happens with Ark, Systemsetting, dolphin and other KDE applications. The only ones I have installed that work is Spectacle and the system monitor (the new one). Also with Smplayer and Quiterss I have the same problem

I tried installing Krusader, to have an alternative file manager, and it works. BUT after closing it, it doesn’t open anymore. I tried deleting ~/.config/krusaderrc and ~/.local/share/Krusader and it opened, but after closing it again, it gives me “segmentation fault” again

What could be the problem?

Did you run any GUI program as root? Check file permissions in your home directory.

But first, update your system (sudo pacman -Syu) and reboot, and try again.

Hi, the system is up to date

ls -l /home/salvatore

totale 4

lrwxrwxrwx 1 salvatore salvatore   25 13 nov 07.59  coredump -> /var/lib/systemd/coredump
lrwxrwxrwx 1 salvatore salvatore   52 15 ago  2022 'File System' -> '/home/salvatore/.config/chromium/Default/File System'
lrwxrwxrwx 1 salvatore salvatore   21 13 nov 07.59  pkg -> /var/cache/pacman/pkg
drwxr-xr-x 2 salvatore salvatore 4096  4 feb 13.15  Scrivania

ls -l /home/

totale 20
drwx------  2 root      root      16384 16 lug  2022 lost+found
drwx------ 20 salvatore salvatore  4096 13 mar 11.27 salvatore

Did you reboot?

Did you, or did you not, ever run any GUI program with sudo?

Check the permissions in .config and all of it subfolders. No need to output it all, just look if there is something unusual or owned by root.


Did you, or did you not, ever run any GUI program with sudo? For example, sudo krusader or sudo kate? Doing this could cause such a problem.

Check the permissions in .config and all of it subfolders. No need to output it all, just look if there is anything unusual or owned by root.

Hi, thanks for the reply. I gave -s -l in /home/salvatore/.config and all permissions are “salvatore salvatore”

The Quiterss folder, which doesn’t start, has these permissions:

drwxr-xr-x 2 salvatore salvatore 4096 13 mar 10.21 QuiteRss

Wait… a strange thing happened to me

I deactivated the second screen via the plasmoid (switch to the laptop screen) and the applications open again. I reactivated the secondary monitor, and they no longer open

Are you using Wayland or Xorg?

Please share the output of

inxi -Faz


But yesterday I logged out and opened Kde with Wayland, to see how it worked and what state it was in

Did it create any problems?

inxi -Faz

  Kernel: 6.2.5-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=d9157889-12e0-4642-a069-95999dd4b678 rw
    lsm=landlock,lockdown,yama,apparmor,bpf zswap.enabled=0 nowatchdog
    nvme_load=YES loglevel=3
  Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Endeavour OS
  Type: Desktop Mobo: Micro-Star model: MS-B0A21 v: 1.1
    serial: <superuser required> UEFI: American Megatrends LLC. v: 8.10
    date: 07/23/2021
  Info: model: AMD Ryzen 5 5600G with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
    process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000C
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2312 high: 3595 min/max: 1400/4464 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2992 2: 1400
    3: 2563 4: 3008 5: 2774 6: 1400 7: 3595 8: 2774 9: 1400 10: 3044 11: 1400
    12: 1400 bogomips: 93463
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s ports: active: DP-2 off: HDMI-A-1
    empty: DP-1 bus-ID: 04:00.0 chip-ID: 1002:1638 class-ID: 0300 temp: 34.0 C
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
    s-diag: 581mm (22.86")
  Monitor-1: DP-2 pos: primary model: HP 22w serial: <filter> built: 2019
    res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2 size: 476x268mm (18.74x10.55")
    diag: 546mm (21.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-1 note: disabled model: Samsung T22C300
    built: 2012 res: 1920x1080 dpi: 102 gamma: 1.2
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.2.5-arch1-1) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound API: ALSA v: k6.2.5-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8168 v: 8.051.02-NAPI modules: r8169 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 02:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:24fb class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-2.1:4 chip-ID: 8087:0aa7 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 937.12 GiB used: 667.36 GiB (71.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
    SDBPNPZ-256G-1032 size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 21111000 temp: 38.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD2500BEVT-22ZCT0 size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A11 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500LM021-1KJ152
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: YXM1 scheme: MBR
  ID-1: / raw-size: 61.8 GiB size: 60.52 GiB (97.94%) used: 21.41 GiB (35.4%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
    used: 139.7 MiB (28.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 48.33 GiB size: 47.27 GiB (97.81%)
    used: 6.19 GiB (13.1%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 6.77 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 41.8 C mobo: N/A gpu: amdgpu temp: 35.0 C
  Fan Speeds (RPM): N/A
  Processes: 307 Uptime: 56m wakeups: 0 Memory: 13.53 GiB
  used: 4.58 GiB (33.8%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: 1350 pm: pacman pkgs: 1332
  libs: 300 tools: pamac,yay pm: flatpak pkgs: 18 Shell: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.25

Typically just logging into a Wayland session won’t create issues with your X11 session. They live somewhat separately (not entirely). I had had some weird issues with plasmoids being out of date and unmaintained. Is this one a default KDE option or an third party installed such as Wunderground?

I have only one 3rd party plasmoid, Event Calendar. It’s a very famous plasmoid so if it creates this problem I think it might spread, I have to go find the comments about it.

In any case, the plasmoid for turning the monitor on and off is an official KDE plasmoid

Create a new user and test if this happens on the new user as well.
If not, it’s a session/user configuration file problem. :person_shrugging:

With a new user it seems that the problem is not there, but I have to admit that switching users would be a bit problematic for me.

I have one questions:

Which file should I avoid copying to not have the same problem again? Because some configurations I necessarily have to copy them, I can’t lose that file

At the moment it seems that deleting ~/.config/kdeglobals will fix the situation. I’m not sure which line is causing the problem

It’s your system, you must have changed something. Only you can narrow it down.