Second screen does not fully render on login when using picom (black rectangle)

Hello!! I’m rather new here. I think I found the fix to this problem but I’m posting in case someone else had the same issue and to check if there’s a better solution.
So, I have two monitors, my laptop’s (1366x768) (on the left) and another one connected by HDMI (1920x1080) (The one in the picture). Sometimes on login my right screen would look like the picture here. Logging out and logging in again had a chance of fixing it, but I’d say this happened like half of the time so it was pretty much a coin-flip.
The black rectangle doesn’t cover neither the mouse or the bar, but covers the wallpaper and any app below (welcome app should be below it in the picture).
I thought the following topics could be related (sorry if this is not how I should quote other topics):

But mine did not affect the bar, and I had no problem with sleep.
I had a theory for the size of the visible area, subtracting the width of my monitors (1920 - 1366) gave a reasonable number for it. So it seemed like something was putting my right monitor at the leftmost (like overlapping the two).
My looks like this:

xrandr --output eDP1 --mode 1366x768 --pos 0x156 --rotate normal --output DP1 --off --output HDMI1 --primary --mode 1920x1080 --pos 1366x0 --rotate normal --output HDMI2 --off --output VIRTUAL1 --off

I tried running it again to see if it fixed it (this solved someone’s issue on the first linked topic) but it did not. I also tried restarting i3 but that didn’t fix it either, I had to log in again.
So, it was neither i3, nitrogen nor xrandr.
It must be picom then?
I then tried killing picom and tada! screen was no longer censored. Starting it again also didn’t cause any problems.
To enable picom I just uncommented the line from the i3-config for default settings.

# using default config 
exec_always --no-startup-id picom -b

TL;DR: Starting picom on login has a chance of causing pic related.

So, if I got this right, this happens when picom starts before runs, right?
Should I just add some delay for picom’s startup?