Second hard drive doesn't show up in Thunar

Hi there,
yesterday I installed EndeavourOS i3-wm on my desktop computer.
The installation process was straightforward.
I have 2 hard drives in my computer and wanted to make the 2nd one available.
I followed this guide to setup the second hard drive:

This is the output of lsblk:

NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
sda                                             8:0    0 931,5G  0 disk  
└─sda1                                          8:1    0 931,5G  0 part  /mnt/externaldrive
sdb                                             8:16   1  29,5G  0 disk  
├─sdb1                                          8:17   1   2,5G  0 part  /run/media/kon/EOS_202404
└─sdb2                                          8:18   1   159M  0 part  
nvme0n1                                       259:0    0 931,5G  0 disk  
├─nvme0n1p1                                   259:1    0     1G  0 part  /boot/efi
└─nvme0n1p2                                   259:2    0 930,5G  0 part  
  └─luks-957abfec-d212-4d0d-aaed-a3226713e308 254:0    0 930,5G  0 crypt /

This is the output of ls -l /mnt:

total 4
drwxrwxrwx 3 root root 4096 26. Jun 10:59 externaldrive

This is the output of cat /etc/fstab:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=3346-5C55                                          /boot/efi     vfat    fmask=0137,dmask=0027   0 2 
/dev/mapper/luks-957abfec-d212-4d0d-aaed-a3226713e308   /             ext4    noatime                 0 1 
tmpfs                                                   /tmp          tmpfs   noatime,mode=1777       0 0 
LABEL=externaldrive /mnt/externaldrive ext4 defaults,user 0 2

Here is a screenshot of thunar. You can see a thumbdrive being recognized. But the second drive doesn’t show up.

Also, e.g. in Steam I can not set the second drive as an installation location.

Does anyone know, how to fix this?

What happens if you mount the drive in your /home folder instead of mnt?
I suspect its not giving you permissions to to the device and permissions are set for root.

maybe instead of /mnt/external do /home/external

just noticed

LABEL=externaldrive /mnt/externaldrive ext4 defaults,user 0 2

I don’t think you need user for anything but NTFS.

I would run lsblk -f and get the UUID for the mounted device and mount using the UUID.


@thefrog That fixed the issue for me (mounting in ~/home and mount using UUID). Thank you so much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.