Second Display won't show content after update

Thanks, I’ll use this as the solution temporarily until a update comes out to fix it.

So, I installed the lts kernel, and deleted the kscreen folder, restarted, and now it apparently works??? It dosen’t stop working after the lock screen pops up.

And there it happened again. This is very random so i won’t post anymore on this post until the problem is fixed.

Are you using an AMD Ryzen CPU? Found two other forum posts with similar issue. Seems plasma needs to iron out a new bug but wondering if it affects only amd users.

Yes, I am using an AMD Ryzen CPU. Specifically AMD Ryzen 5800X.

1 Like

Hopefully gets fixed soon. Maybe worth submitting a bug report to KDE, the more people do it the faster it will hopefully get fixed. Why it affects AMD is strange, if it is related. I would try main and lts kernels. If problem persist might really be related to recent plasma update.

The problem persists on both main and lts kernels, I will see if i can send a bug report to KDE.

1 Like

Plasma has now released a new version with some fixes, I will use it and mark this post as fixed if it works now.

Still no luck for me. My system recognizes that there’s another screen, but once I enable it, there’s just a black area added to my main display. I can actually move my whole desktop like the map in an RTS game, by hitting the screen’s edges with my cursor. The second display that I just enabled in the settings, though? Still no signal.

KDE Plasma 5.26.1 with Nvidia and Intel here.

I have opened a kde bug report, and it got merged with multiple others.
https://bugs.kde.org/show_bug.cgi?id=460341

2 Likes

An easier temporary fix instead of deleting the kscreen folder, is to find out what your displays are called with xrandr | grep connected, and issuing the following command
Note that in your case the --right-of flag may be --left-of depending on where your second display is.
And replace HDMI-0 with what your xrandr identifies your second display as.
Also replace DP-0 with your main display.
After --rate you put your screens refresh rate (most commonly 60)

xrandr --output HDMI-0 --right-of DP-0 --rate 144 --mode 1920x1080

Then, the screen will be working temporarily.

1 Like

Just wondering if you could then use autorandr to save that profile and start it automatically by placing the command autorandr --change, similar to what I use for i3wm.

Not sure where you do this in KDE with sddm, perhaps .xinit or ~/.xprofile or similar in the user home folder.

https://wiki.archlinux.org/title/Xprofile

Until reboot or logout/in?

Well, It’s really random. Sometimes the screen dosen’t work after the computer has been in lock mode on sddm, and sometimes after restart.

Perhaps the idea I posted above could work because it automatically recognizes your current monitor layout you saved upon login from your display manager. I also use this on other wm like dwm and qtile. It simply uses xrandr and starts this profile at login. But autorandr is a bit easier/flexible to my opinion.

That would probably work.

The direct instructions are here. It’s also similar to arandr, but I personally prefer autorandr…

It’s also in the arch repo and can be installed with sudo pacman -S autorandr

Good luck!

Well, there are a few separate posts about this, which should be merged into one if possible. I started this one: https://forum.endeavouros.com/t/lost-one-of-two-displays-for-one-user-only/32936

I also filed a bug report with KDE, as have others, and they are merged into this one: https://bugs.kde.org/show_bug.cgi?id=460341

Since only the Triage guy Nate Graham who is seemingly always on duty, has so far looked into it, but no one who may be able to help has even chimed in at all, and it’s been a week now.

So, I think if more of you will join in over there and make the issue more urgent, it will get fixed sooner. Trying to find workarounds here, although may help, aren’t an actual solution, and it’s their stuff, so they should be in the best position to help.

Also: I do have a Ryzen 7 5800X CPU, but it’s not an APU (No Graphics), and am using an MSI NVIDIA 1080 Graphics card, with both monitors on it.

It seems to only happen when a system puts the monitors in suspend. If you never let it, then you will not have the problem, and once it happens, nothing seams to bring back the lost monitor. It’s like KDE can’t find it at all, because it’s not looking! :crazy_face:

Are the monitors hooked to display port or Hdmi? Do you have a multi-monotor conf file?

https://wiki.archlinux.org/title/multihead#Configuration_using_xorg.conf

The one that stopped working is the display port. The card has two outputs: one HDMI and one Display port.

I do not have an /etc/X11/xorg.conf.d/10-monitor.conf file, but if I did, those would be system wide, and I have the problem in one user account (started on login after it went into suspend mode) but not the other user account where both monitors work as they should. It is user specific, not system wide. If it’s a file setting then it should be in a users home directory somewhere.