Sddm greeter doesn't appear after system upgrade, "sddm-helper exited with 6"

After doing pacman -Syu today, I cannot get the sddm greeter to show up.

At first I suspected that X11 doesn’t start, so I checked /var/log/Xorg.0.log. There it said something like

aiglx error dlopen of /usr/lib64/dri/i965_dri.so failed

Which was weird because I’m p sure it should be i915. I did some googling and found out that mesa dropped support for older CPUs (I have a Haswell), so I installed mesa-amber, which is supposed to have legacy support.

Sure enough this eliminated the error from the Xorg log. But the greeter still didn’t show up. So I checked the sddm output. Ther it simply says

(WW) DAEMON: Auth: sddm-helper exited with 6

I don’t know what this means and why it is not showing a proper error message. I’m stuck.

Since I don’t have a desktop environment, and I am writing this on my phone, it wouldn’t be trivial to post the full logs. But if necessary I can post photos of my screen.

System info:
EndeavourOS on a ThinkPad t440s
Intel i3-4300U with integrated HD 4400

Someone reminded me to check journalctl:


I dont know what this means but it looks scary.

Ok I’m actually getting something from the Xorg log after all:

On the suggestion of a friend I first removed xf86-video-intel and rebooted, and then added MODULES=(i915) to mkinitcpio.conf and ran sudo mikinitcpio -P, and then rebooted, but neither changed anything visibly about the issue.

Do you have internet connection? If so you can send the logs using cli log tools given here

System info:

https://clbin.com/uH0rc

journalctl:

https://clbin.com/YVEkS

Xorg.0.log:

https://clbin.com/uWtsT

sddm doesn’t produce any output anymore, it just hangs.

I think the issue is here:

Apr 19 23:16:17 hauke-thinkpad dbus-daemon[382]: [system] Activating via systemd: service name='org.freedesktop.home1' unit='dbus-org.freedesktop.home1.service' requested by ':1.25' (uid=0 pid=8659 comm="sudo pacman -S --config /etc/pacman.conf -- inxi")
Apr 19 23:16:17 hauke-thinkpad dbus-daemon[382]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
Apr 19 23:16:17 hauke-thinkpad sudo[8659]: pam_systemd_home(sudo:auth): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.

I got similar error messages during my incomplete Endeavouros ARM installs, that I had to fix by installing the missing packages.
I don’t have an handle on whats wrong here but doing these steps might help you:

  1. Update your system in the tty using sudo pacman -Syu
  2. Enable lightdm `sudo systemctl enable lightdm.service
  3. Reboot.
1 Like

I also had to disable sddm.service and remove the symlink in order to enable lightdm. Unfortunately the lightdm greeter also doesn’t work. Here are the new logs:

https://clbin.com/EwOJL
https://clbin.com/uLA0E

After reinstalling xf86-video-intel and running mkinitcpio -P, because the log said module “intel” not found, the issue has taken a new shape:

With lightdm, the system becomes unresponsive while showing nothing but a blinking command line cursor in the upper left corner.

With sddm, a mouse cursor appears and can be moved, but everything else remains a black screen.

What Kernel are you using? Have you tried switching the kernel?

1 Like

I’m using lts54 in order to avoid a system crash that only occurs on newer kernels when running games with vulkan.

I just tried booting with regular linux-lts. It changes nothing.

So, I can actually start an xfce session with startxfce4. It seems that the issue is confined to the display manager.

Though I cannot start a plasma session this way.

Also it seems Qt apps have trouble launching.

Check which packages were updated and you"ll find the problem.

If you do it again, post Xorg log from that boot. It is strange that your posted Xorg logs report they can’t find the intel driver module…

but this (partial update) can take only this far, it may seem.
I hope I’m wrong of course.

There is also a tty DM (look in archwiki), IIRC called ly(?). Or setup your account to start with xinit (noDE).

1 Like

Here’s the Xorg log
https://clbin.com/TMSM0

The output of grep -i 'removed\|installed\|warning\|error\|upgraded' /var/log/pacman.log | grep 2022-04- | eos-sendlog
https://clbin.com/pGRf7

But again, only the journalctl looks like it has sddm-related errors in it:
https://clbin.com/ojMNA

Apr 20 10:46:09 hauke-thinkpad libvirtd[544]: cannot open directory '/home/hauke/Downloads': No such file or directory
Apr 20 10:46:09 hauke-thinkpad libvirtd[544]: internal error: Failed to autostart storage pool 'Downloads': cannot open directory '/home/hauke/Downloads': No such file or directory

Sure you do not have done something else before your issue?
users home is present?

ls /home

ly works, but once I log into a plasma session, kwin_x11 and ksplashqml crash with these error messages:

https://clbin.com/ZccWV
https://clbin.com/OZ8KB

@joekamprad yes I’m sure because I’m running an xfce session rn and uploading logs from my home folder.

/home/hauke/Downloads also exists, albeit as a symlink to another partition, which might not have been mounted at the time of that error.

I see ananicy?

Forgot why I installed it, just uninstalled.

How are your qt apps working? Can you open normally kde apps from xfce?
SDDM and kde are qt based and there were upgrades on qt (among the many…).
If you use qt5ct/kvantum and modify settings, do they apply to qt apps? Check the logs for crashes or errors.

It is really strange issue, so we can only speculate for now… :person_shrugging:

Edit: One more strange thing is that you have nvidia and nv-utils installed, while it seems there is no nvidia card… :face_with_head_bandage:

Yes I noticed the Nvidia stuff too, and honestly have no idea why I have it. I already uninstalled it.

I can launch Dolphin, Qt5 Settings, soulseekqt, but
Scribus crashes with this: https://clbin.com/Ba23n
kdeconnect with this: https://clbin.com/2NLC0
kdenlive with this: https://clbin.com/X8AE4

clearly something is wrong with FBConfig and QSurfaceFormat

This mail indicates that it might be due to the drivers after all https://www.mail-archive.com/mitk-users@lists.sourceforge.net/msg08422.html

I find drivers on Linux really hard to understand. Maybe this output of pacman -Ss mesa\|intel | grep Installed says something? I’m honestly not sure which packages I actually need:

multilib/lib32-vulkan-intel 22.0.1-3 (2.2 MiB 9.0 MiB) (Installed)
multilib/lib32-mesa-amber 21.3.8-2 (7.0 MiB 41.1 MiB) (Installed)
multilib/lib32-glu 9.0.2-2 (138.3 KiB 349.6 KiB) (Installed)
community/onednn 2.5.2-1 (5.5 MiB 27.5 MiB) (Installed)
community/libva-utils 2.14.0-1 (487.5 KiB 2.5 MiB) (Installed)
community/libmfx 22.3.0-1 (56.6 KiB 285.8 KiB) (Installed)
community/intel-opencl-clang 13.0.0.r5+g1490bd4-1 (96.0 KiB 969.9 KiB) (Installed)
community/intel-mkl 2020.4.304-1 (155.2 MiB 820.5 MiB) (Installed)
community/intel-media-sdk 22.3.0-1 (3.6 MiB 27.7 MiB) (Installed)
community/intel-media-driver 22.3.1-1 (5.2 MiB 32.9 MiB) (Installed)
community/intel-graphics-compiler 1:1.0.10840-1 (10.2 MiB 49.9 MiB) (Installed)
community/intel-gmmlib 22.1.2-1 (249.3 KiB 1.4 MiB) (Installed)
community/enblend-enfuse 4.2.r1524+h4c30a326b3f4-2 (1.2 MiB 5.0 MiB) (Installed)
extra/xf86-video-intel 1:2.99.917+916+g31486f40-2 (716.1 KiB 2.2 MiB) [xorg-drivers] (Installed)
extra/whois 5.5.13-1 (40.6 KiB 159.3 KiB) (Installed)
extra/vulkan-mesa-layers 22.0.1-3 (261.0 KiB 644.0 KiB) (Installed)
extra/vulkan-intel 22.0.1-3 (2.3 MiB 9.0 MiB) (Installed)
extra/tbb 2021.5.0-1 (358.9 KiB 1.9 MiB) (Installed)
extra/mesa-utils 8.4.0-7 (30.3 KiB 101.3 KiB) (Installed)
extra/mesa-demos 8.4.0-7 (1.5 MiB 7.5 MiB) (Installed)
extra/mesa-amber 21.3.8-4 (7.3 MiB 43.4 MiB) (Installed)
extra/libva-intel-driver 2.4.1-2 (1.0 MiB 7.8 MiB) (Installed)
extra/glu 9.0.2-2 (142.9 KiB 358.8 KiB) (Installed)
core/ipw2200-fw 3.1-8 (117.9 KiB 562.9 KiB) (Installed)
core/ipw2100-fw 1.3-10 (117.8 KiB 604.2 KiB) (Installed)

You’re on a Haswell processor? You should probably be using mesa, not mesa-amber.

Remove the xf86-video-intel package, it tends to cause problems.

2 Likes