SDDM fails to stop on reboot and shutdown


I have KDE with SDDM as my DE. I’ve been using Wayland for a while because it feels more responsive. I have a desktop on Arch Linux and my laptop is running EndeavourOS. I have an issue specific to my laptop where SDDM fails to stop and I need to wait the 90 seconds timeout for systemd to kill it when I reboot or shutdown my device. This issue does not happen on my desktop running Arch.

Not a Plasma user here but I found a couple of bug reports describing similar issue as yours. You might want to look into it and investigate further:

Good luck and welcome to EnOS’ forum!

1 Like

I tested a few things from those links, none have worked. What I haven’t tried is downgrading kernel and I also haven’t tried setting Wayland in sddm.conf yet.

As mentioned before, I am not using Plasma so I haven’t been able to verify the suggested solutions in those inks. Hopefully some of Plasma users on the forum will chime in with some suggestions.

Best of luck!

I think I found the same issue, and going to SDDM-git solved for me.

doesn’t it force you to adopt all git packages related to KDE Plasma as well? I would like to avoid that on my laptop as it’s just a Ryzen 5 3500U and compiling AUR git packages to update my DE all the time would take a lot of time.


I never have these problems on plasma kde. :thinking:

1 Like

SDDM-git gives me a black screen. I used an Arch live environment and downgrade to reinstall sddm.

Same here even if the reason is probably different

Years ago after few times having problems with sddm and other tools like this I decided to deactivate and uninstall this unnecessary bloat/crap. It is only a cosmtic thing.
I am starting X through .xinitrc from console only typing my username, hitting Enter, typing the password and Enter again.
Sure, if you like the login window it is not a solution. But I like it minimalistic and it is one thing which never can break anything.

Yes but I’d like to use Wayland. This is not really a solution. The problem does not happen on X11.

Until they fix it you can drop into an TTY1 so…CTRL+ALT+F1.

Jumping TTYs does stop it before the kill timer.

1 Like

There is an update to sddm right now.

the update didn’t fix it. it’s the third one since the issue appeared.

Then it’s not sddm that’s the problem. :man_shrugging:

What could it be if not SDDM when it’s SDDM that stalls the shutdown process for 90 seconds unless I switch between tty1 and 2?

I have no idea but i never have this on plasma. My shutdown is quick.

Edit: 3-4 seconds at the most.

1 Like

It’s a real thing. I have the same issue on my arch install. Still haven’t figured out what is wrong.

1 Like

It’s very strange as mine shuts down almost instantly.