SDDM fails after blacklisting descrete graphics

I’m trying to setup PCI passthrough for VM and it was going ok until I could no longer load my login screen after blacklisting nvidia graphics. Got an error: [FAILED] failed to start simple desktop display manager. Other services start after that, like radarr, sonarr, but then it gets stuck in console screen and I have to reboot in safe mode.

Do I have to reset SDDM? Do I have to reset xorg? How do I do that? I don’t want to bork my system any worse.

Installed optimus manager and switched to Intel graphics hoping it would fix the issue. Now I can’t boot even in recovery mode. :poop:

Hello @His_Turdness

The only thing i can suggest is check out these two videos.

I tried different display managers, tried logging in in console and running startx, nothing works. “No screens found”. My xorg and display manager must be all screwed up.

At this point I should just reinstall the system, but I’ve managed to lose my installer USB media. :expressionless:

Did you mean nvidia drivers? If the proprietary driver nvidia is installed, nouveau is blacklisted.

You should remove “/etc/modprobe.d/nouveau.conf” and purge nvidia.

At least earlier nvidia (.run) overwrote some system files (at least on Ubuntu). Sometimes only a reinstall of xorg after purging nvidia helped.

Btw., the question with the whole thing is whether nouveau and passtrough are working together at all.

“Cannot remove: no such file or directory.”

How do I purge nvidia?

How do you have installed?

NVidia drivers? Installed the proprietary drivers with pamac, I think. That was a long time ago. Do I just need to uninstall them? I’ve set the KVM modules so that vfio took over the GPU and Intel graphics should be fine. The only thing not working is SDDM (not starting) and X (no screens error).

Here’s what happens if I login without graphics and run “startx”:

It would be great, of course, if you would show the complete kernel line (and meaningfully not as an image - this is pure ASCII).

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX

The name and path of the log file are also displayed: “/home/miikka/.local/share/xorg/Xorg.0.log”.

You said you blacklisted it. So you can and should also uninstall nvidia.

pamac remove nvidia*

I can only take pics with my phone. :neutral_face: Don’t know how I would be able to upload logs without GUI.

Here’s the kernel line:


Here’s the xorg log:

So, it’s trying to load the NVidia drivers, then trying to load Intel, but can’t and defaulting to previous, which does not show any screens (cause the GPU is disabled/blacklisted)?

  1. Remove the “vfio-pci.ids” option!
  2. Purge the proprietary driver nvidia!

Installed GDM, enabled and started it. Used the login screen to boot GNOME DE (not xorg) and I’m in!!! It was that easy!

Sure, the xorg problem isn’t fixed.

If I remove the vfio-pci.ids option, doesn’t that mean that my PCI passthrough will stop working? That’s not what I want.

But thanks for the help so far. I’ll continue to work on this.

You don’t want to use the Nvidia GPU (I understand that, don’t I?). What do you need passtrough for an Intel IGP?

I’m trying to use my NVidia GPU with virtual windows 10, with PCI passthrough. Host system will use iGPU.

@His_Turdness
More info…

https://wiki.archlinux.org/index.php/PCI_passthrough_via_OVMF

Yes, I had successfully setup my passthrough. That’s why my system didn’t want to load graphics, xorg was/is still set on my NVidia card.

Trying to reset xorg to work with my Intel graphics later today, with the waylan GUI.

Ok… Trying to reset xorg was a bad idea. I deleted everything possible related to xorg/X/X11 and reinstalled. End result is that now even GDM/Wayland doesn’t work and I’m stuck with no GUI again. :sob:

FIXED!!!

After days of scratching my head and trying different things, I reinstalled xorg-xkbcomp and ran X and it worked!!! I had tried pretty much everything before. :poop:

2 Likes