SDDM does not log me in after restoring backup with Timeshift. SEND HELP

So i reformatted my OS drive to seperate my home and root dirs and i’ve installed them back using timeshift.

On boot i get the screen below. Any help deeply appreciated.

Just a guess: Boot into a live usb. Chroot into the installation.
Run lsblk -f in a terminal to get the UUID of your partitions. Then edit the /etc/fstab file and replace old UUID with the new one. Save and exit chroot. Reboot into your installation.

Side note: I am not sure if formatting and using timeshift to restore is a correct way of achieving what you wanted. I would’ve created a partition and edited fstab to auto mount the new partition in my home directory. This, again, might not be the best way. The more experienced members here will have better ideas.

1 Like

Ok, so. My fstab was correct. Totally my fault for misdirecting you with the post title.

My grub entries needed to be updated with the new uuid’s. Done this by a live distro i had lying around and installed grub-customizer. It automaticly edited my grub entries with the new uuid’s.

Now i can boot into my original endeavour os install. However i cannot login with my user on sddm. When i type in the correct password, KDE starts loading but throws me back to sddm login prompt.

1 Like

About KDE I have no idea. Never used it, sorry. Also, I am still not convinced that timeshift is a right way of doing what you wanted.

No problem. You can still edit the post title. If you change it to something that is more accurate, then probably someone who knows will surely pass by and help you. :pray:

1 Like

A quick web search on “move home directory to seperate partition” led me to the solutions.

Turns out sddm wasn’t able to find the home folder (because it wasn’t listed on the fstab), so, by your suggestion, I edited fstab with the proper protocol thanks to the website i found and rebooted successfully to my restored install.


Good to see you solved it. Let me learn something new. Thanks :pray: