Scroll wheel never worked for me

After almost a year with this awesome os I think it’s time to solve the problem of the scroll wheel, it never worked for me and I tried with different mice, where should I start to look?

Hello @Dewizzer
What desktop are you using?
Use this command to get the name of the device.

sudo libinput list-devices

Then you could check if scroll is enabled? Replace name of device with yours.

xinput list-props "name of device"

The first command is fairly long and you just need the name of the mouse. Then check with the second command if scroll is enabled.

Thanks Rick, I see that the scroll is not enabled, how do I enable it? Desktop is xfce.

Are you able to show the xniput list-props “name of your device” Can you post it?

Device ‘Logitech USB Optical Mouse’:
Device Enabled (178): 1
Coordinate Transformation Matrix (180): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Natural Scrolling Enabled (315): 0
libinput Natural Scrolling Enabled Default (316): 0
libinput Scroll Methods Available (317): 0, 0, 1
libinput Scroll Method Enabled (318): 0, 0, 0
libinput Scroll Method Enabled Default (319): 0, 0, 0
libinput Button Scrolling Button (320): 2
libinput Button Scrolling Button Default (321): 2
libinput Button Scrolling Button Lock Enabled (322): 0
libinput Button Scrolling Button Lock Enabled Default (323): 0
libinput Middle Emulation Enabled (324): 0
libinput Middle Emulation Enabled Default (325): 0
libinput Accel Speed (326): 0.000000
libinput Accel Speed Default (327): 0.000000
libinput Accel Profiles Available (328): 1, 1
libinput Accel Profile Enabled (329): 1, 0
libinput Accel Profile Enabled Default (330): 1, 0
libinput Left Handed Enabled (331): 0
libinput Left Handed Enabled Default (332): 0
libinput Send Events Modes Available (300): 1, 0
libinput Send Events Mode Enabled (301): 0, 0
libinput Send Events Mode Enabled Default (302): 0, 0
Device Node (303): “/dev/input/event12”
Device Product ID (304): 1133, 49271
libinput Drag Lock Buttons (333):
libinput Horizontal Scroll Enabled (334): 1

Where did you see it was disabled? In the other command?

Edit: I’m not exactly sure where it has to be enabled or why it’s not working in the first place. It may be that a conf file can be created or changed in libinput or xorg. I think someone that has more knowledge maybe can give a better answer. :blush:

This is quite vague.

The scroll wheel of each mouse you tried doesn’t work on one PC?

The scroll wheel of one mouse doesn’t work on one PC?

No scroll wheels have ever worked with any combination of mice and PC?

The scroll wheel doesn’t work within the live environment, and also doesn’t work within the installed OS?

The scroll wheel doesn’t work within any OS?

So, final question: in what way and in what situations does the scroll wheel not work? Scrolling? Clicking? Which situations, which applications, and which desktop environments?

Did it work at any point at all, ever?

I’ve never come across a situation where mouse with scroll wheel has a default setting of “scrolling disabled”. Indeed, I don’t think I’ve ever seen a desktop environment settings window that exposes scrolling, e.g. MATE:

No setting to enable or disable scroll wheel scrolling.


This is similar settings in Xfce also. I have never had any problems with scrolling either. Strange :mouse2:

1 Like

I was vague that’s true, as I already said I’m using xfce. The click works but every mouse I tried doesn’t scroll the pages up and down with the wheel, not a major problem for me but since I’m sticking with this os I was curious to solve it.

Yes in the other command.

Have you tried the mouse in all the different usb ports?

Edit: Also does the mouse work if booted on the live ISO?

OK, but what about the other questions? Do the mice work in another PC? Does this mouse work in a live environment on this PC? Which “pages” won’t it scroll? Has it ever worked? Have you tried a different USB port, and/or disconnecting other USB devices?

Also just to verify - this is a real PC and not a virtual machine?


Program solaar is a helper for Logitech devices.

But first you should study this problem more, as adviced above.
Try different USB ports. Find a mouse and a PC where scroll wheel works, then try that mouse on your machine.

i got a logitec mx ergo, as its predecessor has its scroll issues

it works here. but slow… on the x11 side i could make with a python script to speed up… is just a bit hassle on some models of logitec i notice… but scrol should work??? in sway found the setting to scroll faster here some how without the wheel programm

what i miss is exact model name of the mouse…

somemodels can be funky in my opinion :slight_smile: