Screwed system after latest python update

Well, I seem to have a Laurel & Hardy situation.
Pacman update was blocked because of my installed Python 3.12, so I removed it. Pacman -Syu completed. Rebooted and my system was very sluggish, felt like running at 1 fps. Tried to yay, but Python builds failed that ere dependent on python310. Installed python310 using yay, but build failed due to libcuda, etc.(?).
Shutdown. Kernel panic on shutdown.
Hang on boot now at “Flush Journal to Persistent Storage.”

Le sigh.

Edit: hit reset, system booted and is running at normal speed. I guess it was update constipation. Attempting to yay now.

1 Like

this was a bit destructive for the system i bet…
You will miss half of the system OS packages with this action.

My thinking was, if packages depend on it, pacman will install the version they need.
It is still installed, and the file date of /usr/bin/python3.12 is 4/23, so it must not have removed it.

yay continues to fail to build 3.10.

gcc -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now          -Wl,-z,pack-relative-relocs -flto=auto -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now          -Wl,-z,pack-relative-relocs -flto=auto -fno-semantic-interposition -flto -fuse-linker-plugin -ffat-lto-objects -flto-partition=none -g -fprofile-generate -Xlinker -export-dynamic -o python Programs/python.o -L. -lpython3.10 -lcrypt -ldl  -lm   -lm 
LD_LIBRARY_PATH=/home/john/.cache/yay/python310/src/Python-3.10.14:/nix/store/a30cchbinr8g8ppv8wxkjgp48zdp4040-nvidia-x11-545.29.02-6.8.7/lib;/nix/store/959yp9jjqm3b6nyblq8k4cvzzz6jbwl7-cudatoolkit-11.8.0-lib/lib;/nix/store/0m0kl19qmwvzq36ann76fbds6ccrjayc-cudnn-;/nix/store/myw67gkgayf3s2mniij7zwd79lxy8v0k-gcc-12.3.0-lib/lib ./python -E -S -m sysconfig --generate-posix-vars ;\
if test $? -ne 0 ; then \
	echo "generate-posix-vars failed" ; \
	rm -f ./pybuilddir.txt ; \
	exit 1 ; \
/bin/sh: line 1: /nix/store/959yp9jjqm3b6nyblq8k4cvzzz6jbwl7-cudatoolkit-11.8.0-lib/lib: No such file or directory
/bin/sh: line 1: /nix/store/0m0kl19qmwvzq36ann76fbds6ccrjayc-cudnn- No such file or directory
/bin/sh: line 1: /nix/store/myw67gkgayf3s2mniij7zwd79lxy8v0k-gcc-12.3.0-lib/lib: No such file or directory
generate-posix-vars failed
make[3]: *** [Makefile:615: pybuilddir.txt] Error 1
make[3]: Leaving directory '/home/john/.cache/yay/python310/src/Python-3.10.14'
make[2]: *** [Makefile:531: build_all_generate_profile] Error 2
make[2]: Leaving directory '/home/john/.cache/yay/python310/src/Python-3.10.14'
make[1]: *** [Makefile:507: profile-gen-stamp] Error 2
make[1]: Leaving directory '/home/john/.cache/yay/python310/src/Python-3.10.14'
make: *** [Makefile:519: profile-run-stamp] Error 2
==> ERROR: A failure occurred in build().
 -> error making: python310-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
python310 - exit status 4

Edit: just noticed the LD_LIBRARY_PATH left from when I tried NixOS. Trying again.

I moved your help request out of notifcations forum :wink:

1 Like

and first of all stop proceed random commands on your system wait for someone helping if ypu are unsure.

Why you want to build python_10 ?
You should first get your system fixed how you would be able to build packages on a broken system?

Current python = python 3.12.3-1

You do not need to build this manually. it’s a package from repository.

What needs to get rebuilded are only AUR builds depending on python not python itself.

Thanks. These commands aren’t random. I wasn’t unsure that I didn’t need LD_LIBRARY_PATH set.

I need python 2.10 because I need Tensorflow 2.14 for one of my projects.
I also need python 3.11 because I need Tensorflow 2.15.
Unfortunately, the Tensorflow authors break compatibility with existing models every time they do a .X release.

There was also an update to python 3.10 from 3.10.14-1 to 3.10.14-2. After removing the LD_LIBRARY_PATH, it built correctly.

Something (not me) seems to have removed python 3.11, so I’m installing that from the aur now.

Okay, python 3.11 is built, created my venv again, so I’m back in business.


1 Like

If you need other versions of Python, I would strongly suggest using pyenv.


So the issue was only partly related to the python update itself, was not that clear in the first place from the given information.

and indeed i would suggest the same:

I create venvs with the different versions of Python that I need, then pip install packages and it works well. I’ll look at pyenv though.
For anything I use system-wide (like dvc), I use pipx or homebrew.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.