Screen turning on/off when gaming

I recently got a new 4k monitor (previously had two 1080 monitors, never had a problem). Everything is mostly fine until i start up a 3d game. Fullscreen or windowed doesn’t seem to matter. Ive tried different HDMI cables, searched around for solutions, cant find anything . when I’m playing any 3d game, my monitor will constantly go blank than come back on, like the monitor will loose the signal than it will come back. very annoying. it does this rarely outside a game, maybe only once in a few days, but it will go crazy when gaming. As a last resort, i would try another distro, but i really don’t want to go that far if i don’t have to.

Any help would be greatly appreciated. if there’s any thing i need to do, please say and I’ll try my best.

Here is some of my PC info.

  Kernel: 6.3.1-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.27.4
    Distro: EndeavourOS
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX B550-I GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2423
    date: 08/11/2021
  Info: 6-core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP cache: L2: 3 MiB
  Speed (MHz): avg: 2907 min/max: 2200/4650 cores: 1: 2847 2: 2874 3: 3134
    4: 2700 5: 3700 6: 2873 7: 3591 8: 2200 9: 3700 10: 2200 11: 2200 12: 2874
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    driver: amdgpu v: kernel
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 driver: X:
    loaded: amdgpu unloaded: modesetting dri: radeonsi gpu: amdgpu
    resolution: 3840x2160~60Hz
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon RX 580 Series
    (polaris10 LLVM 15.0.7 DRM 3.52 6.3.1-arch1-1)
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  API: ALSA v: k6.3.1-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.70 status: active
  Device-1: Intel Ethernet I225-V driver: igc
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: 3c:7c:3f:82:6a:82
  Local Storage: total: 8.41 TiB used: 4.9 TiB (58.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 250GB
    size: 232.89 GiB
  ID-3: /dev/sda vendor: Samsung model: SSD 870 QVO 4TB size: 3.64 TiB
  ID-4: /dev/sdb vendor: Samsung model: SSD 870 QVO 4TB size: 3.64 TiB
  ID-1: / size: 218.54 GiB used: 79.58 GiB (36.4%) fs: ext4
    dev: /dev/nvme1n1p2
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme1n1p3
  System Temperatures: cpu: 38.0 C mobo: 32.0 C gpu: amdgpu temp: 56.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 802
  Processes: 284 Uptime: 26m Memory: 31.26 GiB used: 3.15 GiB (10.1%)
  Shell: Bash inxi: 3.3.26

Did you read into this yet?

Thank you for the reply. Sadly nothing I could find seemed to help. As far as I can tell VRR is disabled. I did have a good look through everything, unless i missed something, nothing seemed to really pertain to my issue. But I do appreciate the help, thank you.

Welp… I’m gonna say this is solved. It seems it may have been a hardware issue. I did suspect this before, but I was hoping it would be something simpler. Bought a new higher wattage PSU, which I’m thinking was the culprit. being at the lower wattage, it was fine at 1080, but at 4k, my PC needed more power, especially while playing a heavier 3d game. I also replaced my GPU as well, just in-case (it was on the old side). So far, doing what I’ve done before, the issue is not happening, so I’m hoping its all good now (I hope).

Did you also change the display cable (hdmi or display port)? a faulty cable could also cause this type of problems.That’s where I’d start debugging these symptoms. It’s the least costly part to swap.

Thank you for the reply. I have done this, I bought a few cables to try, even an 8k cable just for the heck of it. Sadly the problem persisted.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.